aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/netcdf/Makefile')
-rw-r--r--science/netcdf/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 0b4465af8dad..e93513e47bbb 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= netcdf
-PORTVERSION= 3.6.1
+PORTVERSION= 3.6.2
CATEGORIES= science
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/ \
http://sunpoet.net/distfiles/
@@ -15,31 +15,23 @@ MASTER_SITE_SUBDIR= . old
MAINTAINER= sunpoet@sunpoet.net
COMMENT= Library for machine-independent, array-oriented data access
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-
CONFLICTS= hdf-4.*
-CONFIGURE_ENV= CPPFLAGS="-fPIC -DPIC -Df2cFortran"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --enable-shared --mandir=${PREFIX}/man --disable-f77
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
+
+USE_BZIP2= YES
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAN1= ncdump.1 ncgen.1
-MAN3= netcdf.3 netcdf.3f
-
-post-build:
- @(cd ${WRKSRC}/libsrc && \
- ${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
- @(cd ${WRKSRC}/cxx && \
- ${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
+MAN3= netcdf.3
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/ncdump
- @${STRIP_CMD} ${PREFIX}/bin/ncgen
- ${INSTALL_DATA} ${WRKSRC}/libsrc/libnetcdf.so ${PREFIX}/lib/libnetcdf.so.1
- ${LN} -sf libnetcdf.so.1 ${PREFIX}/lib/libnetcdf.so
- ${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
- ${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
+ @${STRIP_CMD} ${PREFIX}/bin/ncdump ${PREFIX}/bin/ncgen
+ ${LN} -fs libnetcdf.so.4 ${PREFIX}/lib/libnetcdf.so
+ ${LN} -fs libnetcdf_c++.so.4 ${PREFIX}/lib/libnetcdf_c++.so
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in COPYRIGHT README RELEASE_NOTES