aboutsummaryrefslogtreecommitdiff
path: root/science/orthanc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/orthanc/Makefile')
-rw-r--r--science/orthanc/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index eae453aa5e4d..7814c28a1491 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= orthanc
-PORTVERSION= 0.9.1
+PORTVERSION= 0.9.3
CATEGORIES= science graphics net www
MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/orthanc/:main \
http://www.montefiore.ulg.ac.be/~jodogne/Orthanc/ThirdPartyDownloads/:mongoose
@@ -21,7 +21,6 @@ BUILD_DEPENDS= gtest-config:${PORTSDIR}/devel/googletest
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libjsoncpp.so:${PORTSDIR}/devel/jsoncpp \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
- libglog.so:${PORTSDIR}/devel/glog \
libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libboost_system.so:${PORTSDIR}/devel/boost-libs \
@@ -56,13 +55,11 @@ GROUPS= orthanc
# cmake variables to tell that mongoose is not presented on the host OS and
# should be build together with the software instead.
# https://www.mail-archive.com/mongoose-users@googlegroups.com/msg00625.html
-post-extract:
+post-patch:
${MKDIR} ${WRKSRC}/ThirdPartyDownloads
${CP} ${DISTDIR}/${DIST_SUBDIR}/mongoose-3.8.tgz ${WRKSRC}/ThirdPartyDownloads
# Orthanc hardcodes /usr/local paths for libs and includes.
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/Resources/CMake/Compiler.cmake
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/Resources/CMake/JsonCppConfiguration.cmake
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/Resources/CMake/SQLiteConfiguration.cmake
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/Resources/CMake/*.cmake
# There is no way to disable building of test units without a patch, on other
# hand it brings only one build dependency (devel/googletest) and running it was