aboutsummaryrefslogtreecommitdiff
path: root/science/psi3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/psi3/Makefile')
-rw-r--r--science/psi3/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index b684c1ed9364..2159c78cea71 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= psi3
PORTVERSION= 3.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= SF/psicode/psi/${PORTVERSION} \
http://www.psicode.org/doc/:doc \
@@ -45,17 +45,18 @@ LAPACK= -lalapack -lptcblas
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_FORTRAN= yes
+USES= fortran gmake
CONFIGURE_ARGS= --with-cc=${CC} \
--with-cxx=${CXX} \
--with-fc=${FC} \
+ --with-opt="${CFLAGS}" \
--with-lapack="${LAPACK}" \
--with-blas="${BLAS}" \
--datadir=${PREFIX}/share/psi3 \
--docdir=${WRKSRC}/tmpdoc/ \
--with-libdirs="-L${LOCALBASE}/lib" \
--with-libs="-lcompat"
+CFLAGS+= -Wno-error=return-type
NO_STAGE= yes
.include <bsd.port.pre.mk>