aboutsummaryrefslogtreecommitdiff
path: root/science/py-h5py/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/py-h5py/Makefile')
-rw-r--r--science/py-h5py/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
new file mode 100644
index 000000000000..a9d959da798a
--- /dev/null
+++ b/science/py-h5py/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: h5py
+# Date created: Jun 22, 2009
+# Whom: TAOKA Fumiyoshi
+#
+# $FreeBSD$
+#
+
+PORTNAME= h5py
+PORTVERSION= 1.2.0
+CATEGORIES= science python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= fmysh@iijmio-mail.jp
+COMMENT= A general-purpose Python interface to the HDF5 library
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= hdf5.0:${PORTSDIR}/science/hdf5
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+
+.include <bsd.port.mk>