aboutsummaryrefslogtreecommitdiff
path: root/science/xmds/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/xmds/Makefile')
-rw-r--r--science/xmds/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/science/xmds/Makefile b/science/xmds/Makefile
new file mode 100644
index 000000000000..3a0228c6d7d6
--- /dev/null
+++ b/science/xmds/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xmds
+# Date created: 2006-07-17
+# Whom: EelVex
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmds
+DISTVERSION= 1.5-2
+CATEGORIES= science
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mplekos@physics.upatras.gr
+COMMENT= XMDS is a code generator that integrates equations;
+
+BUILD_DEPENDS= ${LOCALBASE}/include/fftw.h:${PORTSDIR}/math/fftw
+
+MAN1= loadxsil.1 xmds.1 xsil2graphics.1
+
+HAS_CONFIGURE= YES
+
+CONFIGURE_ARGS= --with-fftw-path=${LOCALBASE}
+
+.include <bsd.port.mk>