aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/flounder/Makefile4
-rw-r--r--science/peekabot/Makefile14
-rw-r--r--science/vmd/Makefile3
3 files changed, 8 insertions, 13 deletions
diff --git a/science/flounder/Makefile b/science/flounder/Makefile
index a5162810c2e6..800df2362791 100644
--- a/science/flounder/Makefile
+++ b/science/flounder/Makefile
@@ -8,7 +8,7 @@
PORTNAME= flounder
PORTVERSION= 0.40
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= science
MASTER_SITES= http://www2.enel.ucalgary.ca/~vigmond/flounder/
EXTRACT_SUFX= .tgz
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A quick way to visualize regularly spaced 4D data
-LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk \
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
ungif:${PORTSDIR}/graphics/libungif \
png:${PORTSDIR}/graphics/png
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
index 6c99d2edf195..5be899d56bc0 100644
--- a/science/peekabot/Makefile
+++ b/science/peekabot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= peekabot
PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.7.x/ \
http://distfiles.officialunix.com/
@@ -20,17 +20,11 @@ LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV= LDFLAGS="`fltk-config --ldflags`" \
+ CPPFLAGS="`fltk-config --cflags`"
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 4.2+
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/vmd/Makefile b/science/vmd/Makefile
index b556b54e819a..7c1fa2080fe3 100644
--- a/science/vmd/Makefile
+++ b/science/vmd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vmd
PORTVERSION= 1.8.7
+PORTREVISION= 1
CATEGORIES= science graphics python tcl tk
MASTER_SITES= http://jedi.ks.uiuc.edu/~johns/raytracer/files/0.98.7/:tachyon \
http://www.ks.uiuc.edu/Research/vmd/extsrcs/:stride
@@ -21,7 +22,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend \
${PYNUMERIC}
LIB_DEPENDS= tcl85:${PORTSDIR}/lang/tcl85 \
tk85:${PORTSDIR}/x11-toolkits/tk85 \
- fltk:${PORTSDIR}/x11-toolkits/fltk \
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk \
netcdf:${PORTSDIR}/science/netcdf
RUN_DEPENDS= ${PYNUMERIC}