aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/kst/Makefile5
-rw-r--r--science/kst2/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/science/kst/Makefile b/science/kst/Makefile
index 8448a1bfe6f5..96e12b3fc96f 100644
--- a/science/kst/Makefile
+++ b/science/kst/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
USE_GETTEXT= yes
OPTIONS= NETCDF "Enable netcdf file support" off \
@@ -31,7 +32,7 @@ MAN1= kst.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
+.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 8448a1bfe6f5..96e12b3fc96f 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
USE_GETTEXT= yes
OPTIONS= NETCDF "Enable netcdf file support" off \
@@ -31,7 +32,7 @@ MAN1= kst.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
+.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif