aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/avogadro/Makefile3
-rw-r--r--science/kalzium/Makefile3
-rw-r--r--science/kst2/Makefile3
-rw-r--r--science/massxpert/Makefile3
-rw-r--r--science/paraview/Makefile3
-rw-r--r--science/qtresistors/Makefile3
-rw-r--r--science/step/Makefile3
7 files changed, 7 insertions, 14 deletions
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 1272c7d00f5b..66fb29a5c13c 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= openbabel.3:${PORTSDIR}/science/openbabel
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GL= glu
-USE_QT_VER= 4
-QT_COMPONENTS= gui opengl network linguist_build \
+USE_QT4= gui opengl network linguist_build \
qmake_build moc_build rcc_build uic_build
USE_CMAKE= yes
CMAKE_ARGS= -DENABLE_GLSL=OFF \
diff --git a/science/kalzium/Makefile b/science/kalzium/Makefile
index 782869829523..3c4fedc207f1 100644
--- a/science/kalzium/Makefile
+++ b/science/kalzium/Makefile
@@ -30,8 +30,7 @@ USE_KDE4= kdehier kdelibs kdeprefix automoc4
KDE4_BUILDENV= yes
USE_OCAML= yes
NO_OCAML_RUNDEPENDS= yes
-USE_QT_VER= 4
-QT_COMPONENTS= dbus designer opengl script xml \
+USE_QT4= dbus designer opengl script xml \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 45b929e03882..798b51f5bd5e 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl
LATEST_LINK= kst2
USE_CMAKE= yes
-USE_QT_VER= 4
-QT_COMPONENTS= gui xml designer svg opengl \
+USE_QT4= gui xml designer svg opengl \
qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
index 1689dc767657..61bfcb02e3d9 100644
--- a/science/massxpert/Makefile
+++ b/science/massxpert/Makefile
@@ -16,10 +16,9 @@ COMMENT= The massXpert software for (bio)chemists
LICENSE= GPLv3
-USE_QT_VER= 4
USE_CMAKE= yes
USE_LDCONFIG= yes
-QT_COMPONENTS= gui xml rcc_build qmake_build uic_build moc_build \
+USE_QT4= gui xml rcc_build qmake_build uic_build moc_build \
svg
MAN7= massxpert-data.7
MAN1= massxpert.1
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 5359a834ed71..207fd7a49b94 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18 \
freetype.9:${PORTSDIR}/print/freetype2 \
expat.6:${PORTSDIR}/textproc/expat2
-USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build rcc_build uic_build \
+USE_QT4= qmake_build moc_build rcc_build uic_build \
linguist_build assistant_run qt3support \
dbus designer gui help-tools network script \
sql svg xml webkit assistantclient
diff --git a/science/qtresistors/Makefile b/science/qtresistors/Makefile
index 5be7ec70fcd6..a46b8cb033be 100644
--- a/science/qtresistors/Makefile
+++ b/science/qtresistors/Makefile
@@ -15,8 +15,7 @@ DISTNAME= 118297-qtResistors-201001102229
MAINTAINER= g.veniamin@googlemail.com
COMMENT= Calculate resistance of resistor by the colors on the resistor
-USE_QT_VER= 4
-QT_COMPONENTS= gui qmake_build uic_build moc_build
+USE_QT4= gui qmake_build uic_build moc_build
WRKSRC= ${WRKDIR}/qtResistors
diff --git a/science/step/Makefile b/science/step/Makefile
index 0e1eda188146..cc69bcb0f6e3 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -25,8 +25,7 @@ CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
KDE4_BUILDENV= yes
-USE_QT_VER= 4
-QT_COMPONENTS= opengl xml moc_build qmake_build rcc_build uic_build
+USE_QT4= opengl xml moc_build qmake_build rcc_build uic_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes