aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/InsightToolkit/Makefile1
-rw-r--r--science/InsightToolkit/files/patch-Modules_ThirdParty_MINC_src_libminc_CMakeLists.txt27
2 files changed, 28 insertions, 0 deletions
diff --git a/science/InsightToolkit/Makefile b/science/InsightToolkit/Makefile
index c4bc3e5429b5..00c45cca48bc 100644
--- a/science/InsightToolkit/Makefile
+++ b/science/InsightToolkit/Makefile
@@ -3,6 +3,7 @@
PORTNAME= InsightToolkit
PORTVERSION= 4.13.0
+PORTREVISION= 1
CATEGORIES= science biology
MASTER_SITES= SF/itk/itk/${ITK_VER}
diff --git a/science/InsightToolkit/files/patch-Modules_ThirdParty_MINC_src_libminc_CMakeLists.txt b/science/InsightToolkit/files/patch-Modules_ThirdParty_MINC_src_libminc_CMakeLists.txt
new file mode 100644
index 000000000000..561df0edeabd
--- /dev/null
+++ b/science/InsightToolkit/files/patch-Modules_ThirdParty_MINC_src_libminc_CMakeLists.txt
@@ -0,0 +1,27 @@
+--- Modules/ThirdParty/MINC/src/libminc/CMakeLists.txt.orig 2017-12-29 06:00:13 UTC
++++ Modules/ThirdParty/MINC/src/libminc/CMakeLists.txt
+@@ -387,8 +387,8 @@ SET(LIBMINC_LIBRARIES ${LIBMINC_LIBRARY} ${HDF5_LIBRAR
+ SET(LIBMINC_STATIC_LIBRARIES ${LIBMINC_LIBRARY_STATIC} ${HDF5_LIBRARIES} ${NIFTI_LIBRARIES} ${ZLIB_LIBRARY})
+
+ IF(UNIX)
+- SET(LIBMINC_LIBRARIES ${LIBMINC_LIBRARIES} m dl ${RT_LIBRARY})
+- SET(LIBMINC_STATIC_LIBRARIES ${LIBMINC_STATIC_LIBRARIES} m dl ${RT_LIBRARY})
++ SET(LIBMINC_LIBRARIES ${LIBMINC_LIBRARIES} m ${RT_LIBRARY})
++ SET(LIBMINC_STATIC_LIBRARIES ${LIBMINC_STATIC_LIBRARIES} m ${RT_LIBRARY})
+ ENDIF(UNIX)
+
+ SET(minc_LIB_SRCS ${minc2_LIB_SRCS} ${minc_common_SRCS})
+@@ -425,11 +425,11 @@ ENDIF(NOT LIBMINC_USE_SYSTEM_NIFTI AND NOT LIBMINC_EX
+ #EXPORT(TARGETS ${LIBMINC_LIBRARY} FILE "${LIBMINC_EXPORTED_TARGETS}.cmake")
+
+ IF(UNIX)
+- TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY} m dl )
++ TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY} m )
+
+ IF(LIBMINC_BUILD_SHARED_LIBS)
+ ADD_LIBRARY(${LIBMINC_LIBRARY_STATIC} STATIC ${minc_LIB_SRCS} ${minc_HEADERS} ${volume_io_LIB_SRCS} ${volume_io_HEADERS} )
+- TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY_STATIC} ${HDF5_LIBRARY} ${NIFTI_LIBRARIES} ${ZLIB_LIBRARY} ${RT_LIBRARY} m dl )
++ TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY_STATIC} ${HDF5_LIBRARY} ${NIFTI_LIBRARIES} ${ZLIB_LIBRARY} ${RT_LIBRARY} m )
+ IF(LIBMINC_MINC1_SUPPORT)
+ TARGET_LINK_LIBRARIES(${LIBMINC_LIBRARY} ${NETCDF_LIBRARY})
+ ENDIF(LIBMINC_MINC1_SUPPORT)