aboutsummaryrefslogtreecommitdiff
path: root/security/altivore
diff options
context:
space:
mode:
Diffstat (limited to 'security/altivore')
-rw-r--r--security/altivore/Makefile16
-rw-r--r--security/altivore/files/pkg-message.in (renamed from security/altivore/pkg-message)2
-rw-r--r--security/altivore/pkg-plist6
3 files changed, 11 insertions, 13 deletions
diff --git a/security/altivore/Makefile b/security/altivore/Makefile
index 6a1bac4e8281..8857aefa4812 100644
--- a/security/altivore/Makefile
+++ b/security/altivore/Makefile
@@ -8,7 +8,8 @@
PORTNAME= altivore
PORTVERSION= 0.9.3
CATEGORIES= security
-MASTER_SITES= http://samy.kerneled.org/stuff/
+MASTER_SITES= http://80.237.203.14/media/directory06/uploads/ \
+ http://mirror.inerd.com/FreeBSD/distfiles/altivore/
DISTNAME= altivore
EXTRACT_SUFX= .c
@@ -18,9 +19,10 @@ COMMENT= A publically disclosed (neither GPL nor open-source) ala Carnivore src
RESTRICTED= License does not allow redistribution in any form\
(source, code or otherwise)
+SUB_FILES= pkg-message
+
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_REINPLACE= yes
do-extract:
@${MKDIR} ${WRKDIR}
@@ -30,12 +32,8 @@ post-patch:
@${REINPLACE_CMD} -e "s/ //" ${WRKDIR}/${DISTFILES}
do-install:
- @${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
- @${INSTALL_DATA} ${WRKDIR}/${DISTFILES} \
- ${PREFIX}/share/examples/${PORTNAME}
- @${INSTALL_DATA} ${PKGMESSAGE} \
- ${PREFIX}/share/examples/${PORTNAME}/README
-
- @${SED} -e "s!/usr/local/!${PREFIX}/!" ${PKGMESSAGE}
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKDIR}/${DISTFILES} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${PKGMESSAGE} ${EXAMPLESDIR}/README
.include <bsd.port.mk>
diff --git a/security/altivore/pkg-message b/security/altivore/files/pkg-message.in
index 6df370670d8b..11cda06623f3 100644
--- a/security/altivore/pkg-message
+++ b/security/altivore/files/pkg-message.in
@@ -3,7 +3,7 @@ discussing.
A copy of the altivore source code was installed as
-/usr/local/share/examples/altivore/altivore.c
+%%EXAMPLESDIR%%/altivore.c
Compiling, or any other use, should be conducted after reading of
the source's license agreement. Read the source code, it contains
diff --git a/security/altivore/pkg-plist b/security/altivore/pkg-plist
index 2ce91ba1f792..01839b56b222 100644
--- a/security/altivore/pkg-plist
+++ b/security/altivore/pkg-plist
@@ -1,3 +1,3 @@
-share/examples/altivore/README
-share/examples/altivore/altivore.c
-@dirrm share/examples/altivore
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/altivore.c
+@dirrm %%EXAMPLESDIR%%