aboutsummaryrefslogtreecommitdiff
path: root/security/amavisd-new
diff options
context:
space:
mode:
Diffstat (limited to 'security/amavisd-new')
-rw-r--r--security/amavisd-new/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index a80d73241f35..662389c68418 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -8,7 +8,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.6.4
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
@@ -46,6 +46,7 @@ AMAVISGROUP?= vscan
AMAVISDIR?= /var/amavis
AMAVISQUARANTINE?= /var/virusmails
DAEMON?= /usr/sbin/daemon -p
+HOSTNAME!= /bin/hostname
OPTIONS= BDB "Use BerkeleyDB for nanny/cache/snmp" on \
SNMP "Install amavisd snmp subagent" off \
@@ -244,6 +245,8 @@ post-patch:
-e "s|/var/lib/amavis|${AMAVISDIR}|" \
-e 's|$$log_level = 2;|$$log_level = 0;|' \
-e "s|/var/virusmails|${AMAVISQUARANTINE}|" \
+ -e "s|\$localhost_name = \'localhost\';|\$localhost_name = \'${HOSTNAME}\';|g" \
+ -e 's|/var/run/clamav/clamd|/var/run/clamav/clamd.sock|g' \
${WRKSRC}/${i}
.endfor
@${REINPLACE_CMD} "s|/var/amavis/db|${AMAVISDIR}/db|" ${WRKSRC}/amavisd-agent
@@ -257,6 +260,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|/etc/amavisd.conf|${PREFIX}/etc/amavisd.conf|" \
-e "s|/usr/bin/perl|${PERL}|" \
-e "s|/var/amavis|${AMAVISDIR}|g" \
+ -e "s|\$localhost_name = \'localhost\';|\$localhost_name = \'${HOSTNAME}\';|g" \
${WRKSRC}/amavisd
.if defined(AMAVIS_NOAMAVIS)