aboutsummaryrefslogtreecommitdiff
path: root/security/apache-xml-security-c
diff options
context:
space:
mode:
Diffstat (limited to 'security/apache-xml-security-c')
-rw-r--r--security/apache-xml-security-c/Makefile8
-rw-r--r--security/apache-xml-security-c/distinfo5
-rw-r--r--security/apache-xml-security-c/pkg-plist9
3 files changed, 14 insertions, 8 deletions
diff --git a/security/apache-xml-security-c/Makefile b/security/apache-xml-security-c/Makefile
index f537a29f798c..22f0af32ebb7 100644
--- a/security/apache-xml-security-c/Makefile
+++ b/security/apache-xml-security-c/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= xml-security-c
-PORTVERSION= 1.4.0
+PORTVERSION= 1.6.0
CATEGORIES= security
-MASTER_SITES= http://santuario.apache.org/dist/c-library/
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR=santuario/c-library
PKGNAMEPREFIX= apache-
MAINTAINER= janos.mohacsi@bsd.hu
@@ -16,6 +17,7 @@ COMMENT= Apache XML security libraries C version
OPTIONS= XERCES_DEVEL "With Xerces vesion 2.8 (shibboleth2 requires)" on
+USE_OPENSSL= yes
.include <bsd.port.pre.mk>
.if defined(WITH_XERCES_DEVEL)
@@ -29,5 +31,5 @@ CONFIGURE_ARGS+=--with-xerces=${LOCALBASE}
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
-
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
.include <bsd.port.post.mk>
diff --git a/security/apache-xml-security-c/distinfo b/security/apache-xml-security-c/distinfo
index 1c0e3a46add1..e25a9ca7e9e5 100644
--- a/security/apache-xml-security-c/distinfo
+++ b/security/apache-xml-security-c/distinfo
@@ -1,3 +1,2 @@
-MD5 (xml-security-c-1.4.0.tar.gz) = dd9accf6727eb008dbf1dd674d5d4dcc
-SHA256 (xml-security-c-1.4.0.tar.gz) = 955c570a965ab58d021a797ad85ad052ec37d9b8739d9a926d1081fb96c6245f
-SIZE (xml-security-c-1.4.0.tar.gz) = 934876
+SHA256 (xml-security-c-1.6.0.tar.gz) = ccc8abe614bfed814bc772e3904ba1708b5984ec1245500a0be409f8195e0831
+SIZE (xml-security-c-1.6.0.tar.gz) = 865131
diff --git a/security/apache-xml-security-c/pkg-plist b/security/apache-xml-security-c/pkg-plist
index 0395773384ad..dc6d2c91ed3a 100644
--- a/security/apache-xml-security-c/pkg-plist
+++ b/security/apache-xml-security-c/pkg-plist
@@ -12,6 +12,8 @@ include/xsec/canon/XSECXMLNSStack.hpp
include/xsec/dsig/DSIGAlgorithmHandlerDefault.hpp
include/xsec/dsig/DSIGConstants.hpp
include/xsec/dsig/DSIGKeyInfo.hpp
+include/xsec/dsig/DSIGKeyInfoDEREncoded.hpp
+include/xsec/dsig/DSIGKeyInfoExt.hpp
include/xsec/dsig/DSIGKeyInfoList.hpp
include/xsec/dsig/DSIGKeyInfoMgmtData.hpp
include/xsec/dsig/DSIGKeyInfoName.hpp
@@ -46,6 +48,7 @@ include/xsec/enc/OpenSSL/OpenSSLCryptoBase64.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoHash.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoHashHMAC.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoKeyDSA.hpp
+include/xsec/enc/OpenSSL/OpenSSLCryptoKeyEC.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoKeyHMAC.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoKeyRSA.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoProvider.hpp
@@ -57,6 +60,7 @@ include/xsec/enc/XSECCryptoException.hpp
include/xsec/enc/XSECCryptoHash.hpp
include/xsec/enc/XSECCryptoKey.hpp
include/xsec/enc/XSECCryptoKeyDSA.hpp
+include/xsec/enc/XSECCryptoKeyEC.hpp
include/xsec/enc/XSECCryptoKeyHMAC.hpp
include/xsec/enc/XSECCryptoKeyRSA.hpp
include/xsec/enc/XSECCryptoProvider.hpp
@@ -75,6 +79,7 @@ include/xsec/framework/XSECException.hpp
include/xsec/framework/XSECProvider.hpp
include/xsec/framework/XSECURIResolver.hpp
include/xsec/framework/XSECURIResolverXerces.hpp
+include/xsec/framework/XSECVersion.hpp
include/xsec/framework/XSECW32Config.hpp
include/xsec/transformers/TXFMBase.hpp
include/xsec/transformers/TXFMBase64.hpp
@@ -93,6 +98,7 @@ include/xsec/transformers/TXFMURL.hpp
include/xsec/transformers/TXFMXPath.hpp
include/xsec/transformers/TXFMXPathFilter.hpp
include/xsec/transformers/TXFMXSL.hpp
+include/xsec/utils/XSECAutoPtr.hpp
include/xsec/utils/XSECBinTXFMInputStream.hpp
include/xsec/utils/XSECDOMUtils.hpp
include/xsec/utils/XSECNameSpaceExpander.hpp
@@ -153,9 +159,8 @@ include/xsec/xkms/XKMSValidateRequest.hpp
include/xsec/xkms/XKMSValidateResult.hpp
include/xsec/xkms/XKMSValidityInterval.hpp
lib/libxml-security-c.a
-lib/libxml-security-c.la
lib/libxml-security-c.so
-lib/libxml-security-c.so.14
+lib/libxml-security-c.so.16
@dirrm include/xsec/xkms
@dirrm include/xsec/xenc
@dirrm include/xsec/utils/unixutils