aboutsummaryrefslogtreecommitdiff
path: root/security/bsdsfv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/bsdsfv/Makefile')
-rw-r--r--security/bsdsfv/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/bsdsfv/Makefile b/security/bsdsfv/Makefile
new file mode 100644
index 000000000000..e156e8f30252
--- /dev/null
+++ b/security/bsdsfv/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: bsdsfv
+# Date created: 26 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdsfv
+PORTVERSION= 1.18
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A flexible SFV checksum utility
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/bsdsfv
+PORTDOCS= MANUAL
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(INSTALL_PREFIX =\).*$$|\1 ${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>