aboutsummaryrefslogtreecommitdiff
path: root/security/clusterssh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/clusterssh/Makefile')
-rw-r--r--security/clusterssh/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/security/clusterssh/Makefile b/security/clusterssh/Makefile
index 4bf9c744c363..66dcf1146b4d 100644
--- a/security/clusterssh/Makefile
+++ b/security/clusterssh/Makefile
@@ -2,11 +2,8 @@
# $FreeBSD$
PORTNAME= clusterssh
-PORTVERSION= 4.07
-PORTREVISION= 1
+PORTVERSION= 4.09
CATEGORIES= security net
-MASTER_SITES= SF/${PORTNAME}/2.%20ClusterSSH%20Series%204
-DISTNAME= App-ClusterSSH-${PORTVERSION}
MAINTAINER= lx@FreeBSD.org
COMMENT= Controls multiple hosts simultaneously via xterms and ssh
@@ -24,20 +21,28 @@ BUILD_DEPENDS= p5-File-Which>=0:sysutils/p5-File-Which \
p5-Exception-Class>=0:devel/p5-Exception-Class \
p5-Try-Tiny>=0:lang/p5-Try-Tiny \
p5-Tk>=0:x11-toolkits/p5-Tk \
- p5-X11-Protocol>=0:x11/p5-X11-Protocol \
p5-Sort-Naturally>=1:textproc/p5-Sort-Naturally \
+ p5-X11-Protocol>=0:x11/p5-X11-Protocol \
+ p5-X11-Protocol-Other>=0:x11/p5-X11-Protocol-Other \
xterm:x11/xterm
RUN_DEPENDS= p5-Tk>=0:x11-toolkits/p5-Tk \
p5-X11-Protocol>=0:x11/p5-X11-Protocol \
+ p5-X11-Protocol-Other>=0:x11/p5-X11-Protocol-Other \
p5-Exception-Class>=0:devel/p5-Exception-Class \
p5-Try-Tiny>=0:lang/p5-Try-Tiny \
p5-Sort-Naturally>=1:textproc/p5-Sort-Naturally \
xterm:x11/xterm
-TEST_DEPENDS= p5-CPAN-Changes>=0:devel/p5-CPAN-Changes
+TEST_DEPENDS= p5-CPAN-Changes>=0:devel/p5-CPAN-Changes \
+ p5-Test-Differences>=0:devel/p5-Test-Differences \
+ p5-Test-PerlTidy>=0:devel/p5-Test-PerlTidy
USES= perl5
+USE_GITHUB= yes
USE_PERL5= modbuild
+GH_ACCOUNT= duncs
+GH_TAGNAME= 4665a23
+
OPTIONS_SUB= yes
OPTIONS_DEFINE= BASH