aboutsummaryrefslogtreecommitdiff
path: root/security/cops
diff options
context:
space:
mode:
Diffstat (limited to 'security/cops')
-rw-r--r--security/cops/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/cops/Makefile b/security/cops/Makefile
index f7495af34348..a1bc9b73cf4c 100644
--- a/security/cops/Makefile
+++ b/security/cops/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cops
PORTVERSION= 1.04
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.fish2.com/cops/ \
http://komquats.com/distfiles/
@@ -11,6 +12,7 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}+
MAINTAINER= cy@FreeBSD.org
COMMENT= System secureness checker
+USES= perl5 shebangfix
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:S/.//g}+
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= reconfig
@@ -24,6 +26,10 @@ C_SRC= home.chk.c user.chk.c is_able.c is_something.c \
addto.c clearfiles.c filewriters.c members.c tilde.c \
crc.c crc_check.c
+post-patch:
+ @${REINPLACE_CMD} -i '' -e 's|${perl_OLD_CMD}|${perl_CMD}|' \
+ ${WRKSRC}/perl/cops
+
pre-build:
${SED} \
-e 's,^SECURE=/usr/foo/bar,SECURE=${PREFIX}/cops,g' \