aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/cryptopp/Makefile')
-rw-r--r--security/cryptopp/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 0835d4cc6d2c..8a2356bf5210 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -47,6 +47,12 @@ HEADERFILES= 3way.h adler32.h aes.h algebra.h algparam.h arc4.h \
twofish.h validate.h wait.h wake.h winpipes.h words.h \
xormac.h xtr.h xtrcrypt.h zdeflate.h zinflate.h zlib.h
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Does not compile on !i386 and !alpha"
+.endif
+
pre-install:
${STRIP_CMD} ${WRKSRC}/cryptest
do-install:
@@ -62,4 +68,4 @@ do-install:
${CP} ${WRKSRC}/License.txt ${PREFIX}/share/doc/cryptopp/License
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>