aboutsummaryrefslogtreecommitdiff
path: root/security/doscan
diff options
context:
space:
mode:
Diffstat (limited to 'security/doscan')
-rw-r--r--security/doscan/Makefile3
-rw-r--r--security/doscan/distinfo2
-rw-r--r--security/doscan/files/patch-src::results.cc11
-rw-r--r--security/doscan/files/patch-src::subnets.c10
4 files changed, 14 insertions, 12 deletions
diff --git a/security/doscan/Makefile b/security/doscan/Makefile
index 1beae4ecdd98..c1e9eec24e69 100644
--- a/security/doscan/Makefile
+++ b/security/doscan/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= doscan
-PORTVERSION= 0.1.6
+PORTVERSION= 0.2.3
CATEGORIES= security net
MASTER_SITES= http://static.enyo.de/fw/releases/doscan/
@@ -17,6 +17,7 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_GCC= 3.3
DOC_FILES= README
MAN1= doscan.1
diff --git a/security/doscan/distinfo b/security/doscan/distinfo
index d2b4d76f1819..e969e4c250c9 100644
--- a/security/doscan/distinfo
+++ b/security/doscan/distinfo
@@ -1 +1 @@
-MD5 (doscan-0.1.6.tar.gz) = e915c705c69e76d30f65333ea39625b1
+MD5 (doscan-0.2.3.tar.gz) = 7774a590a3f96bc14a28230d50f3aa35
diff --git a/security/doscan/files/patch-src::results.cc b/security/doscan/files/patch-src::results.cc
new file mode 100644
index 000000000000..fb965a5efa19
--- /dev/null
+++ b/security/doscan/files/patch-src::results.cc
@@ -0,0 +1,11 @@
+--- src/results.cc.orig Fri Oct 31 13:41:03 2003
++++ src/results.cc Tue Nov 4 09:29:05 2003
+@@ -392,7 +392,7 @@
+ #ifdef GETHOSTBYADDR_ACCEPTS_CHAR
+ he = gethostbyaddr (reinterpret_cast<char*>(&in), sizeof (in), AF_INET);
+ #else
+-#error Type of first argument to gethostbyaddr() is not known.
++ he = gethostbyaddr ((const char*)(&in), sizeof (in), AF_INET);
+ #endif
+ #endif
+
diff --git a/security/doscan/files/patch-src::subnets.c b/security/doscan/files/patch-src::subnets.c
deleted file mode 100644
index 59a4b80cac6d..000000000000
--- a/security/doscan/files/patch-src::subnets.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/subnets.c.orig Wed Sep 24 13:28:27 2003
-+++ src/subnets.c Wed Sep 24 13:29:59 2003
-@@ -37,7 +37,6 @@
-
- #include <stdio.h>
- #include <stdlib.h>
--#include <malloc.h>
-
- static ipv4_prefix_t *subnets = 0;
- /* list of subnets, terminated by the 0/0 prefix */