aboutsummaryrefslogtreecommitdiff
path: root/security/drweb-sendmail/files/Makefile.libsmutil
diff options
context:
space:
mode:
Diffstat (limited to 'security/drweb-sendmail/files/Makefile.libsmutil')
-rw-r--r--security/drweb-sendmail/files/Makefile.libsmutil20
1 files changed, 20 insertions, 0 deletions
diff --git a/security/drweb-sendmail/files/Makefile.libsmutil b/security/drweb-sendmail/files/Makefile.libsmutil
new file mode 100644
index 000000000000..2e73a9a789a2
--- /dev/null
+++ b/security/drweb-sendmail/files/Makefile.libsmutil
@@ -0,0 +1,20 @@
+# $FreeBSD$
+#
+SENDMAIL_DIR=/usr/src/contrib/sendmail
+.PATH: ${SENDMAIL_DIR}/libsmutil
+
+CFLAGS+=-I${SENDMAIL_DIR}/src -I${SENDMAIL_DIR}/include
+CFLAGS+=-DNEWDB -DNIS -DMAP_REGEX -DNOT_SENDMAIL -D_FFR_MILTER=1
+
+# User customizations to the sendmail build environment
+CFLAGS+=${SENDMAIL_CFLAGS}
+
+LIB= smutil
+
+SRCS+= debug.c errstring.c lockfile.c safefile.c snprintf.c strl.c
+
+INTERNALLIB= true
+NOPIC= true
+INTERNALSTATICLIB= true
+
+.include <bsd.lib.mk>