aboutsummaryrefslogtreecommitdiff
path: root/security/freebsd-update/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/freebsd-update/Makefile')
-rw-r--r--security/freebsd-update/Makefile32
1 files changed, 8 insertions, 24 deletions
diff --git a/security/freebsd-update/Makefile b/security/freebsd-update/Makefile
index 1302f103c64d..272fa2a88cfa 100644
--- a/security/freebsd-update/Makefile
+++ b/security/freebsd-update/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= freebsd-update
-PORTVERSION= 1.3
-PORTREVISION= 1
+PORTVERSION= 1.4
CATEGORIES= security
MASTER_SITES= http://www.daemonology.net/freebsd-update/
-DISTNAME= ${PORTNAME}-client-${PORTVERSION:S/./_/}
MAINTAINER= cperciva@daemonology.net
COMMENT= Fetches and installs binary updates to FreeBSD
@@ -20,32 +18,18 @@ RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff
MAN5= freebsd-update.conf.5
MAN8= freebsd-update.8
-NO_WRKSUBDIR= yes
-ALL_TARGET= verify
-
PKGMESSAGE= ${WRKDIR}/pkg-message
+.ifdef NOPORTDOCS
+MAKE_ENV+= NODOCS=yes
+.endif
+
post-extract:
- @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/freebsd-update \
- > ${WRKSRC}/freebsd-update
+ ${SED} -e "s#PREFIX=/usr/local#PREFIX=${PREFIX}#g" \
+ ${WRKSRC}/freebsd-update > ${WRKSRC}/freebsd-update.new
+ ${MV} ${WRKSRC}/freebsd-update.new ${WRKSRC}/freebsd-update
@${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/pkg-message \
> ${PKGMESSAGE}
- @${CP} ${FILESDIR}/freebsd-update.8 ${WRKSRC}
- @${CP} ${FILESDIR}/freebsd-update.conf.5 ${WRKSRC}
-
-do-install:
- @${MKDIR} ${PREFIX}/freebsd-update
- ${INSTALL_SCRIPT} ${WRKSRC}/freebsd-update ${PREFIX}/sbin
- ${INSTALL_PROGRAM} ${WRKSRC}/verify ${PREFIX}/freebsd-update
- ${INSTALL_DATA} ${WRKSRC}/Makefile ${PREFIX}/freebsd-update
- ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${PREFIX}/freebsd-update
- ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/freebsd-update
- ${INSTALL_DATA} ${WRKSRC}/update.conf \
- ${PREFIX}/etc/freebsd-update.conf.sample
-.if !defined(WITHOUT_MAN)
- ${INSTALL_MAN} ${WRKSRC}/freebsd-update.conf.5 ${PREFIX}/man/man5/
- ${INSTALL_MAN} ${WRKSRC}/freebsd-update.8 ${PREFIX}/man/man8/
-.endif
post-install:
@${CAT} ${PKGMESSAGE}