aboutsummaryrefslogtreecommitdiff
path: root/security/gaim-encryption/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/gaim-encryption/Makefile')
-rw-r--r--security/gaim-encryption/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/gaim-encryption/Makefile b/security/gaim-encryption/Makefile
new file mode 100644
index 000000000000..21cb9f1a4326
--- /dev/null
+++ b/security/gaim-encryption/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gaim-encryption
+# Date created: 2004-05-01
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= gaim-encryption
+PORTVERSION= 2.25
+CATEGORIES= security net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Provides transparent RSA encryption as a Gaim plugin
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/gaim:configure
+RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim
+LIB_DEPENDS= nss3:${PORTSDIR}/security/nss
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= lthack gtk20
+USE_LIBTOOL_VER=13
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/nss/nss"
+CONFIGURE_ARGS= --with-gaim=${WRKDIRPREFIX}${PORTSDIR}/net/gaim/work/gaim*
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WARNING: make sure net/gaim is built with NSS support (it is, by default)"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>