aboutsummaryrefslogtreecommitdiff
path: root/security/gnome-keyring
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnome-keyring')
-rw-r--r--security/gnome-keyring/Makefile14
-rw-r--r--security/gnome-keyring/distinfo6
-rw-r--r--security/gnome-keyring/files/patch-configure22
-rw-r--r--security/gnome-keyring/files/patch-daemon_prompt_gkd-prompt.c11
-rw-r--r--security/gnome-keyring/files/patch-egg_egg-asn1x.c13
-rw-r--r--security/gnome-keyring/files/patch-gcr_gcr-certificate.c14
-rw-r--r--security/gnome-keyring/files/patch-pkcs11_rpc-layer_gck-rpc-dispatch.c11
-rw-r--r--security/gnome-keyring/files/patch-pkcs11_rpc-layer_gkm-rpc-dispatch.c11
-rw-r--r--security/gnome-keyring/pkg-plist92
9 files changed, 114 insertions, 80 deletions
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index f4e78d323888..7c55f7c7fcbc 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/security/gnome-keyring/Makefile,v 1.6 2010/06/23 12:38:25 kwm Exp $
+# $MCom: ports/security/gnome-keyring/Makefile,v 1.98 2010/10/26 08:18:44 kwm Exp $
#
PORTNAME= gnome-keyring
-PORTVERSION= 2.30.3
-PORTREVISION= 1
+PORTVERSION= 2.32.1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,16 +16,19 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A program that keeps passwords and other secrets
LIB_DEPENDS= gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
USE_BZIP2= yes
-USE_GNOME= gnomehack gnomeprefix gtk20 ltverhack intlhack gconf2
+USE_GNOME= gnomehack gnomeprefix gtk20 ltverhack intlhack
USE_GMAKE= yes
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-pam-dir="${PREFIX}/lib"
+CONFIGURE_ARGS= --with-pam-dir="${PREFIX}/lib" \
+ --with-root-certs="${LOCALBASE}/share/certs/ca-root-nss.crt"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-GCONF_SCHEMAS= gnome-keyring.schemas
+GLIB_SCHEMAS= org.gnome.crypto.cache.gschema.xml \
+ org.gnome.crypto.pgp.gschema.xml
.include <bsd.port.mk>
diff --git a/security/gnome-keyring/distinfo b/security/gnome-keyring/distinfo
index c87f432564c7..5c6e7223b8d8 100644
--- a/security/gnome-keyring/distinfo
+++ b/security/gnome-keyring/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-keyring-2.30.3.tar.bz2) = 54cb1835c02a40f27fda73e58da17cc6
-SHA256 (gnome2/gnome-keyring-2.30.3.tar.bz2) = b24e5c6db621897f2a0045f0083e1f878d617f5c801d389c2ce028a2c67e290b
-SIZE (gnome2/gnome-keyring-2.30.3.tar.bz2) = 1592573
+MD5 (gnome2/gnome-keyring-2.32.1.tar.bz2) = 9a8aa74e03361676f29d6e73155786fc
+SHA256 (gnome2/gnome-keyring-2.32.1.tar.bz2) = 31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9
+SIZE (gnome2/gnome-keyring-2.32.1.tar.bz2) = 1619245
diff --git a/security/gnome-keyring/files/patch-configure b/security/gnome-keyring/files/patch-configure
new file mode 100644
index 000000000000..7e8ec000a1bb
--- /dev/null
+++ b/security/gnome-keyring/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure.orig 2010-09-19 12:45:34.000000000 +0000
++++ configure 2010-09-19 12:50:50.000000000 +0000
+@@ -14454,8 +14454,8 @@
+ .SECONDARY: $(gsettings_SCHEMAS)
+
+ gsettings__base_list = \
+- sed "$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g" | \
+- sed "$$!N;$$!N;$$!N;$$!N;s/\n/ /g"
++ sed '\''$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g'\'' | \
++ sed '\''$$!N;$$!N;$$!N;$$!N;s/\n/ /g'\''
+
+ install-gsettings-schemas: $(gsettings_SCHEMAS:.xml=.valid) $(gsettings__enum_file)
+ @$(NORMAL_INSTALL)
+@@ -15058,7 +15058,7 @@
+
+ pam_status="no"
+ if test "$enable_pam" != "no"; then
+- for ac_header in security/pam_modules.h pam/pam_modules.h
++ for ac_header in security/pam_modules.h
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
diff --git a/security/gnome-keyring/files/patch-daemon_prompt_gkd-prompt.c b/security/gnome-keyring/files/patch-daemon_prompt_gkd-prompt.c
deleted file mode 100644
index 1c4cb9ae4a1b..000000000000
--- a/security/gnome-keyring/files/patch-daemon_prompt_gkd-prompt.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- daemon/prompt/gkd-prompt.c.orig 2009-12-21 19:17:13.000000000 -0500
-+++ daemon/prompt/gkd-prompt.c 2009-12-21 19:17:23.000000000 -0500
-@@ -21,6 +21,8 @@
-
- #include "config.h"
-
-+#include <sys/wait.h>
-+
- #include "gkd-prompt.h"
- #include "gkd-prompt-marshal.h"
- #include "gkd-prompt-util.h"
diff --git a/security/gnome-keyring/files/patch-egg_egg-asn1x.c b/security/gnome-keyring/files/patch-egg_egg-asn1x.c
new file mode 100644
index 000000000000..30828f3f61c8
--- /dev/null
+++ b/security/gnome-keyring/files/patch-egg_egg-asn1x.c
@@ -0,0 +1,13 @@
+--- egg/egg-asn1x.c.orig 2010-09-04 12:08:41.000000000 +0200
++++ egg/egg-asn1x.c 2010-09-04 12:10:05.000000000 +0200
+@@ -1988,8 +1988,8 @@ anode_write_integer_ulong (gulong value,
+ guchar buf[sizeof (gulong)];
+ gint bytes, i, off;
+
+- for (i = 0; i < sizeof (ulong); ++i) {
+- off = sizeof (ulong) - (i + 1);
++ for (i = 0; i < sizeof (gulong); ++i) {
++ off = sizeof (gulong) - (i + 1);
+ buf[i] = (value >> (off * 8)) & 0xFF;
+ }
+
diff --git a/security/gnome-keyring/files/patch-gcr_gcr-certificate.c b/security/gnome-keyring/files/patch-gcr_gcr-certificate.c
index 0c910a4c453a..bdf10bf14628 100644
--- a/security/gnome-keyring/files/patch-gcr_gcr-certificate.c
+++ b/security/gnome-keyring/files/patch-gcr_gcr-certificate.c
@@ -1,11 +1,11 @@
---- gcr/gcr-certificate.c.orig 2009-12-16 23:36:19.000000000 -0500
-+++ gcr/gcr-certificate.c 2009-12-16 23:36:28.000000000 -0500
-@@ -156,7 +156,7 @@ calculate_key_size (GcrCertificateInfo *
+--- gcr/gcr-certificate.c.orig 2010-09-04 12:04:30.000000000 +0200
++++ gcr/gcr-certificate.c 2010-09-04 12:04:42.000000000 +0200
+@@ -158,7 +158,7 @@ calculate_key_size (GcrCertificateInfo *
const guchar *data, *params;
- gsize n_data, n_params, n_key;
- guint key_size = 0;
+ gsize n_data, n_params;
+ guint key_size = 0, n_bits;
- guchar *key;
+ guchar *key = NULL;
GQuark oid;
-
- data = egg_asn1_read_element (info->asn1, info->der, info->n_der, "tbsCertificate.subjectPublicKeyInfo", &n_data);
+
+ data = egg_asn1x_get_raw_element (egg_asn1x_node (info->asn1, "tbsCertificate", "subjectPublicKeyInfo", NULL), &n_data);
diff --git a/security/gnome-keyring/files/patch-pkcs11_rpc-layer_gck-rpc-dispatch.c b/security/gnome-keyring/files/patch-pkcs11_rpc-layer_gck-rpc-dispatch.c
deleted file mode 100644
index 0fdeef6bc040..000000000000
--- a/security/gnome-keyring/files/patch-pkcs11_rpc-layer_gck-rpc-dispatch.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- pkcs11/rpc-layer/gck-rpc-dispatch.c.orig 2009-12-16 23:37:26.000000000 -0500
-+++ pkcs11/rpc-layer/gck-rpc-dispatch.c 2009-12-16 23:38:10.000000000 -0500
-@@ -783,7 +783,7 @@ rpc_C_Finalize (CallState *cs)
- {
- CK_SLOT_ID_PTR slots;
- CK_ULONG n_slots, i;
-- CK_RV ret;
-+ CK_RV ret = CKR_OK;
-
- debug (("C_Finalize: enter"));
-
diff --git a/security/gnome-keyring/files/patch-pkcs11_rpc-layer_gkm-rpc-dispatch.c b/security/gnome-keyring/files/patch-pkcs11_rpc-layer_gkm-rpc-dispatch.c
new file mode 100644
index 000000000000..146d8b69da05
--- /dev/null
+++ b/security/gnome-keyring/files/patch-pkcs11_rpc-layer_gkm-rpc-dispatch.c
@@ -0,0 +1,11 @@
+--- pkcs11/rpc-layer/gkm-rpc-dispatch.c.orig 2010-09-04 12:06:44.000000000 +0200
++++ pkcs11/rpc-layer/gkm-rpc-dispatch.c 2010-09-04 12:07:12.000000000 +0200
+@@ -784,7 +784,7 @@ rpc_C_Finalize (CallState *cs)
+ {
+ CK_SLOT_ID_PTR slots;
+ CK_ULONG n_slots, i;
+- CK_RV ret;
++ CK_RV ret = CKR_OK;
+
+ debug (("C_Finalize: enter"));
+
diff --git a/security/gnome-keyring/pkg-plist b/security/gnome-keyring/pkg-plist
index 8094cfb282a5..96646576363d 100644
--- a/security/gnome-keyring/pkg-plist
+++ b/security/gnome-keyring/pkg-plist
@@ -1,35 +1,38 @@
bin/gnome-keyring
bin/gnome-keyring-daemon
+etc/xdg/autostart/gnome-keyring-gpg.desktop
etc/xdg/autostart/gnome-keyring-pkcs11.desktop
etc/xdg/autostart/gnome-keyring-secrets.desktop
etc/xdg/autostart/gnome-keyring-ssh.desktop
-include/gcr/gcr-certificate-basics-widget.h
-include/gcr/gcr-certificate-details-widget.h
-include/gcr/gcr-certificate.h
-include/gcr/gcr-importer.h
-include/gcr/gcr-parser.h
-include/gcr/gcr-types.h
-include/gcr/gcr-unlock-options-widget.h
-include/gcr/gcr.h
+include/gcr/gcr/gcr-certificate-basics-widget.h
+include/gcr/gcr/gcr-certificate-details-widget.h
+include/gcr/gcr/gcr-certificate.h
+include/gcr/gcr/gcr-importer.h
+include/gcr/gcr/gcr-parser.h
+include/gcr/gcr/gcr-simple-certificate.h
+include/gcr/gcr/gcr-types.h
+include/gcr/gcr/gcr-unlock-options-widget.h
+include/gcr/gcr/gcr-unlock-options.h
+include/gcr/gcr/gcr.h
include/gp11/gp11.h
include/gp11/pkcs11.h
include/gp11/pkcs11g.h
include/gp11/pkcs11n.h
-lib/gnome-keyring/devel/gck-ssh-store-standalone.a
-lib/gnome-keyring/devel/gck-ssh-store-standalone.la
-lib/gnome-keyring/devel/gck-ssh-store-standalone.so
-lib/gnome-keyring/devel/gck-user-store-standalone.a
-lib/gnome-keyring/devel/gck-user-store-standalone.la
-lib/gnome-keyring/devel/gck-user-store-standalone.so
+lib/gnome-keyring/devel/gkm-ssh-store-standalone.a
+lib/gnome-keyring/devel/gkm-ssh-store-standalone.la
+lib/gnome-keyring/devel/gkm-ssh-store-standalone.so
+lib/gnome-keyring/devel/gkm-user-store-standalone.a
+lib/gnome-keyring/devel/gkm-user-store-standalone.la
+lib/gnome-keyring/devel/gkm-user-store-standalone.so
lib/gnome-keyring/gnome-keyring-pkcs11.a
lib/gnome-keyring/gnome-keyring-pkcs11.la
lib/gnome-keyring/gnome-keyring-pkcs11.so
-lib/gnome-keyring/standalone/gck-roots-store-standalone.a
-lib/gnome-keyring/standalone/gck-roots-store-standalone.la
-lib/gnome-keyring/standalone/gck-roots-store-standalone.so
-lib/gnome-keyring/standalone/gck-secret-store-standalone.a
-lib/gnome-keyring/standalone/gck-secret-store-standalone.la
-lib/gnome-keyring/standalone/gck-secret-store-standalone.so
+lib/gnome-keyring/standalone/gkm-roots-store-standalone.a
+lib/gnome-keyring/standalone/gkm-roots-store-standalone.la
+lib/gnome-keyring/standalone/gkm-roots-store-standalone.so
+lib/gnome-keyring/standalone/gkm-secret-store-standalone.a
+lib/gnome-keyring/standalone/gkm-secret-store-standalone.la
+lib/gnome-keyring/standalone/gkm-secret-store-standalone.so
lib/libgcr.a
lib/libgcr.la
lib/libgcr.so
@@ -44,28 +47,30 @@ lib/pam_gnome_keyring.so
libdata/pkgconfig/gcr-0.pc
libdata/pkgconfig/gp11-0.pc
libexec/gnome-keyring-prompt
+share/GConf/gsettings/org.gnome.crypto.cache.convert
+share/GConf/gsettings/org.gnome.crypto.pgp.convert
share/dbus-1/services/org.freedesktop.secrets.service
share/dbus-1/services/org.gnome.keyring.service
-share/doc/gcr/ch01.html
-share/doc/gcr/gcr-GcrCertificate.html
-share/doc/gcr/gcr-gcr-certificate-basics-widget.html
-share/doc/gcr/gcr-gcr-certificate-details-widget.html
-share/doc/gcr/gcr-gcr-import-dialog.html
-share/doc/gcr/gcr-gcr-importer.html
-share/doc/gcr/gcr-gcr-initializer.html
-share/doc/gcr/gcr-gcr-parser.html
-share/doc/gcr/gcr-gcr-simple-certificate.html
-share/doc/gcr/gcr-gcr-types.html
-share/doc/gcr/gcr-gcr-xxx.html
-share/doc/gcr/gcr.devhelp
-share/doc/gcr/gcr.devhelp2
-share/doc/gcr/home.png
-share/doc/gcr/index.html
-share/doc/gcr/index.sgml
-share/doc/gcr/left.png
-share/doc/gcr/right.png
-share/doc/gcr/style.css
-share/doc/gcr/up.png
+share/doc/gcr-0/ch01.html
+share/doc/gcr-0/gcr-GcrCertificate.html
+share/doc/gcr-0/gcr-gcr-certificate-basics-widget.html
+share/doc/gcr-0/gcr-gcr-certificate-details-widget.html
+share/doc/gcr-0/gcr-gcr-import-dialog.html
+share/doc/gcr-0/gcr-gcr-importer.html
+share/doc/gcr-0/gcr-gcr-initializer.html
+share/doc/gcr-0/gcr-gcr-parser.html
+share/doc/gcr-0/gcr-gcr-simple-certificate.html
+share/doc/gcr-0/gcr-gcr-types.html
+share/doc/gcr-0/gcr-gcr-xxx.html
+share/doc/gcr-0/gcr-0.devhelp
+share/doc/gcr-0/gcr-0.devhelp2
+share/doc/gcr-0/home.png
+share/doc/gcr-0/index.html
+share/doc/gcr-0/index.sgml
+share/doc/gcr-0/left.png
+share/doc/gcr-0/right.png
+share/doc/gcr-0/style.css
+share/doc/gcr-0/up.png
share/doc/gp11/GP11Module.html
share/doc/gp11/GP11Object.html
share/doc/gp11/GP11Session.html
@@ -92,7 +97,7 @@ share/gcr/ui/gcr-unlock-options-widget.ui
%%DATADIR%%/introspect/introspect-prompt.xml
%%DATADIR%%/introspect/introspect-service.xml
%%DATADIR%%/introspect/introspect-session.xml
-%%DATADIR%%/ui/gkd-prompt.ui
+%%DATADIR%%/ui/gku-prompt.ui
share/locale/ar/LC_MESSAGES/gnome-keyring.mo
share/locale/as/LC_MESSAGES/gnome-keyring.mo
share/locale/ast/LC_MESSAGES/gnome-keyring.mo
@@ -179,12 +184,15 @@ share/locale/zh_TW/LC_MESSAGES/gnome-keyring.mo
@dirrm share/gcr/ui
@dirrm share/gcr
@dirrm share/doc/gp11
-@dirrm share/doc/gcr
+@dirrm share/doc/gcr-0
@dirrm lib/gnome-keyring/standalone
@dirrm lib/gnome-keyring/devel
@dirrm lib/gnome-keyring
@dirrm include/gp11
+@dirrm include/gcr/gcr
@dirrm include/gcr
+@dirrmtry share/GConf/gsettings
+@dirrmtry share/GConf
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES