aboutsummaryrefslogtreecommitdiff
path: root/security/gnome-keyring
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnome-keyring')
-rw-r--r--security/gnome-keyring/Makefile29
-rw-r--r--security/gnome-keyring/distinfo3
-rw-r--r--security/gnome-keyring/files/patch-gnome-keyring-daemon-io.c58
-rw-r--r--security/gnome-keyring/files/patch-gnome-keyring-daemon.c34
-rw-r--r--security/gnome-keyring/files/patch-gnome-keyring.c92
-rw-r--r--security/gnome-keyring/pkg-descr17
-rw-r--r--security/gnome-keyring/pkg-plist64
7 files changed, 0 insertions, 297 deletions
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
deleted file mode 100644
index 47f07b3ba5bd..000000000000
--- a/security/gnome-keyring/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# New ports collection makefile for: gnomekeyring
-# Date Created: 08 December 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnomekeyring
-PORTVERSION= 0.4.7
-PORTREVISION= 1
-CATEGORIES= security gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-keyring/0.4
-DISTNAME= gnome-keyring-${PORTVERSION}
-DIST_SUBDIR= gnome2
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= A program that keeps passwords and other secrets
-
-USE_X_PREFIX= yes
-USE_BZIP2= yes
-USE_GNOME= gnomehack gtk20
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-.include <bsd.port.mk>
diff --git a/security/gnome-keyring/distinfo b/security/gnome-keyring/distinfo
deleted file mode 100644
index a1ca042ccd12..000000000000
--- a/security/gnome-keyring/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (gnome2/gnome-keyring-0.4.7.tar.bz2) = 6c760ec2783ce02152ac9d8ef4471a41
-SHA256 (gnome2/gnome-keyring-0.4.7.tar.bz2) = aaf9e363a95bb7cd7e0f558f6cb0584d026e8a692d5842e6921c5dd56003d736
-SIZE (gnome2/gnome-keyring-0.4.7.tar.bz2) = 394506
diff --git a/security/gnome-keyring/files/patch-gnome-keyring-daemon-io.c b/security/gnome-keyring/files/patch-gnome-keyring-daemon-io.c
deleted file mode 100644
index 9c0e02eb14ff..000000000000
--- a/security/gnome-keyring/files/patch-gnome-keyring-daemon-io.c
+++ /dev/null
@@ -1,58 +0,0 @@
---- gnome-keyring-daemon-io.c.orig Wed May 4 03:17:18 2005
-+++ gnome-keyring-daemon-io.c Sat Jul 16 21:46:13 2005
-@@ -100,14 +100,17 @@ read_unix_socket_credentials (int fd,
- char buf;
-
- #ifdef HAVE_CMSGCRED
-- char cmsgmem[CMSG_SPACE (sizeof (struct cmsgcred))];
-- struct cmsghdr *cmsg = (struct cmsghdr *) cmsgmem;
-+ struct cmsgcred *cred;
-+ union {
-+ struct cmsghdr hdr;
-+ char cred[CMSG_SPACE (sizeof (struct cmsgcred))];
-+ } cmsg;
- #endif
-
- *pid = 0;
- *uid = 0;
-
--#if defined(LOCAL_CREDS) && defined(HAVE_CMSGCRED)
-+#if defined(LOCAL_CREDS) && defined(HAVE_CMSGCRED) && !defined(__FreeBSD__)
- /* Set the socket to receive credentials on the next message */
- {
- int on = 1;
-@@ -126,9 +129,9 @@ read_unix_socket_credentials (int fd,
- msg.msg_iovlen = 1;
-
- #ifdef HAVE_CMSGCRED
-- memset (cmsgmem, 0, sizeof (cmsgmem));
-- msg.msg_control = cmsgmem;
-- msg.msg_controllen = sizeof (cmsgmem);
-+ memset (&cmsg, 0, sizeof (cmsg));
-+ msg.msg_control = (caddr_t) &cmsg;
-+ msg.msg_controllen = CMSG_SPACE (sizeof (struct cmsgcred));
- #endif
-
- again:
-@@ -147,7 +150,8 @@ read_unix_socket_credentials (int fd,
- }
-
- #ifdef HAVE_CMSGCRED
-- if (cmsg->cmsg_len < sizeof (cmsgmem) || cmsg->cmsg_type != SCM_CREDS) {
-+ if (cmsg.hdr.cmsg_len < CMSG_LEN (sizeof (struct cmsgcred)) ||
-+ cmsg.hdr.cmsg_type != SCM_CREDS) {
- g_warning ("Message from recvmsg() was not SCM_CREDS\n");
- return FALSE;
- }
-@@ -168,10 +172,7 @@ read_unix_socket_credentials (int fd,
- return FALSE;
- }
- #elif defined(HAVE_CMSGCRED)
-- struct cmsgcred *cred;
--
-- cred = (struct cmsgcred *) CMSG_DATA (cmsg);
--
-+ cred = (struct cmsgcred *) CMSG_DATA (&cmsg);
- *pid = cred->cmcred_pid;
- *uid = cred->cmcred_euid;
- #else /* !SO_PEERCRED && !HAVE_CMSGCRED */
diff --git a/security/gnome-keyring/files/patch-gnome-keyring-daemon.c b/security/gnome-keyring/files/patch-gnome-keyring-daemon.c
deleted file mode 100644
index 293df59b976f..000000000000
--- a/security/gnome-keyring/files/patch-gnome-keyring-daemon.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- gnome-keyring-daemon.c.orig Tue Jul 20 22:41:27 2004
-+++ gnome-keyring-daemon.c Tue Jul 20 22:43:03 2004
-@@ -121,7 +121,7 @@
- int i;
-
- got_random = FALSE;
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- {
- int fd;
-
-@@ -352,6 +352,22 @@
- app_ref->pathname[len] = 0;
- }
-
-+ }
-+#elif defined(__FreeBSD__)
-+ {
-+ char buffer[1024];
-+ int len;
-+ char *path;
-+
-+ path = g_strdup_printf ("/proc/%d/file", pid);
-+ len = readlink (path, buffer, sizeof (buffer));
-+ g_free (path);
-+
-+ if (len > 0) {
-+ app_ref->pathname = g_malloc (len + 1);
-+ memcpy (app_ref->pathname, buffer, len);
-+ app_ref->pathname[len] = 0;
-+ }
- }
- #endif
-
diff --git a/security/gnome-keyring/files/patch-gnome-keyring.c b/security/gnome-keyring/files/patch-gnome-keyring.c
deleted file mode 100644
index 728352a8b013..000000000000
--- a/security/gnome-keyring/files/patch-gnome-keyring.c
+++ /dev/null
@@ -1,92 +0,0 @@
---- gnome-keyring.c.orig Fri May 27 03:54:22 2005
-+++ gnome-keyring.c Sat Jul 16 21:49:24 2005
-@@ -36,6 +36,7 @@
- #include <string.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <sys/uio.h>
- #include <sys/un.h>
- #include <stdarg.h>
-
-@@ -253,11 +254,39 @@ write_credentials_byte_sync (int socket)
- {
- char buf;
- int bytes_written;
-+#if defined(HAVE_CMSGCRED) && (!defined(LOCAL_CREDS) || defined(__FreeBSD__))
-+ union {
-+ struct cmsghdr hdr;
-+ char cred[CMSG_SPACE (sizeof (struct cmsgcred))];
-+ } cmsg;
-+ struct iovec iov;
-+ struct msghdr msg;
-+#endif
-+
-+ buf = 0;
-+#if defined(HAVE_CMSGCRED) && (!defined(LOCAL_CREDS) || defined(__FreeBSD__))
-+ iov.iov_base = &buf;
-+ iov.iov_len = 1;
-+
-+ memset (&msg, 0, sizeof (msg));
-+ msg.msg_iov = &iov;
-+ msg.msg_iovlen = 1;
-+
-+ msg.msg_control = (caddr_t) &cmsg;
-+ msg.msg_controllen = CMSG_SPACE (sizeof (struct cmsgcred));
-+ memset (&cmsg, 0, sizeof (cmsg));
-+ cmsg.hdr.cmsg_len = CMSG_LEN (sizeof (struct cmsgcred));
-+ cmsg.hdr.cmsg_level = SOL_SOCKET;
-+ cmsg.hdr.cmsg_type = SCM_CREDS;
-+#endif
-
- again:
-
-- buf = 0;
-+#if defined(HAVE_CMSGCRED) && (!defined(LOCAL_CREDS) || defined(__FreeBSD__))
-+ bytes_written = sendmsg (socket, &msg, 0);
-+#else
- bytes_written = write (socket, &buf, 1);
-+#endif
-
- if (bytes_written < 0 && errno == EINTR)
- goto again;
-@@ -275,11 +304,39 @@ write_credentials_byte (GnomeKeyringOper
- {
- char buf;
- int bytes_written;
-+#if defined(HAVE_CMSGCRED) && (!defined(LOCAL_CREDS) || defined(__FreeBSD__))
-+ union {
-+ struct cmsghdr hdr;
-+ char cred[CMSG_SPACE (sizeof (struct cmsgcred))];
-+ } cmsg;
-+ struct iovec iov;
-+ struct msghdr msg;
-+#endif
-+
-+ buf = 0;
-+#if defined(HAVE_CMSGCRED) && (!defined(LOCAL_CREDS) || defined(__FreeBSD__))
-+ iov.iov_base = &buf;
-+ iov.iov_len = 1;
-+
-+ memset (&msg, 0, sizeof (msg));
-+ msg.msg_iov = &iov;
-+ msg.msg_iovlen = 1;
-+
-+ msg.msg_control = (caddr_t) &cmsg;
-+ msg.msg_controllen = CMSG_SPACE (sizeof (struct cmsgcred));
-+ memset (&cmsg, 0, sizeof (cmsg));
-+ cmsg.hdr.cmsg_len = CMSG_LEN (sizeof (struct cmsgcred));
-+ cmsg.hdr.cmsg_level = SOL_SOCKET;
-+ cmsg.hdr.cmsg_type = SCM_CREDS;
-+#endif
-
- again:
-
-- buf = 0;
-+#if defined(HAVE_CMSGCRED) && (!defined(LOCAL_CREDS) || defined(__FreeBSD__))
-+ bytes_written = sendmsg (op->socket, &msg, 0);
-+#else
- bytes_written = write (op->socket, &buf, 1);
-+#endif
-
- if (bytes_written < 0 && errno == EINTR)
- goto again;
diff --git a/security/gnome-keyring/pkg-descr b/security/gnome-keyring/pkg-descr
deleted file mode 100644
index 75ce77c6ddfd..000000000000
--- a/security/gnome-keyring/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-Gnome-keyring is a program that keep password and other secrets for
-users. It is run as a damon in the session, similar to ssh-agent, and
-other applications can locate it by an environment variable.
-
-The program can manage several keyrings, each with its own master
-password, and there is also a session keyring which is never stored to
-disk, but forgotten when the session ends.
-
-The library libgnome-keyring is used by applications to integrate with
-the gnome keyring system. However, at this point the library hasn't been
-tested and used enought to consider the API to be publically
-exposed. Therefore use of libgnome-keyring is at the moment limited to
-internal use in the gnome desktop. However, we hope that the
-gnome-keyring API will turn out useful and good, so that later it
-can be made public for any application to use.
-
--- Gnome-keyring README
diff --git a/security/gnome-keyring/pkg-plist b/security/gnome-keyring/pkg-plist
deleted file mode 100644
index 38a1d87e863f..000000000000
--- a/security/gnome-keyring/pkg-plist
+++ /dev/null
@@ -1,64 +0,0 @@
-bin/gnome-keyring-daemon
-include/gnome-keyring-1/gnome-keyring.h
-lib/libgnome-keyring.la
-lib/libgnome-keyring.so
-lib/libgnome-keyring.so.0
-libdata/pkgconfig/gnome-keyring-1.pc
-libexec/gnome-keyring-ask
-share/locale/ar/LC_MESSAGES/gnome-keyring.mo
-share/locale/az/LC_MESSAGES/gnome-keyring.mo
-share/locale/bg/LC_MESSAGES/gnome-keyring.mo
-share/locale/bn/LC_MESSAGES/gnome-keyring.mo
-share/locale/bs/LC_MESSAGES/gnome-keyring.mo
-share/locale/ca/LC_MESSAGES/gnome-keyring.mo
-share/locale/cs/LC_MESSAGES/gnome-keyring.mo
-share/locale/cy/LC_MESSAGES/gnome-keyring.mo
-share/locale/da/LC_MESSAGES/gnome-keyring.mo
-share/locale/de/LC_MESSAGES/gnome-keyring.mo
-share/locale/el/LC_MESSAGES/gnome-keyring.mo
-share/locale/en_CA/LC_MESSAGES/gnome-keyring.mo
-share/locale/en_GB/LC_MESSAGES/gnome-keyring.mo
-share/locale/es/LC_MESSAGES/gnome-keyring.mo
-share/locale/et/LC_MESSAGES/gnome-keyring.mo
-share/locale/eu/LC_MESSAGES/gnome-keyring.mo
-share/locale/fa/LC_MESSAGES/gnome-keyring.mo
-share/locale/fi/LC_MESSAGES/gnome-keyring.mo
-share/locale/fr/LC_MESSAGES/gnome-keyring.mo
-share/locale/gl/LC_MESSAGES/gnome-keyring.mo
-share/locale/hr/LC_MESSAGES/gnome-keyring.mo
-share/locale/hu/LC_MESSAGES/gnome-keyring.mo
-share/locale/id/LC_MESSAGES/gnome-keyring.mo
-share/locale/is/LC_MESSAGES/gnome-keyring.mo
-share/locale/it/LC_MESSAGES/gnome-keyring.mo
-share/locale/ja/LC_MESSAGES/gnome-keyring.mo
-share/locale/ko/LC_MESSAGES/gnome-keyring.mo
-share/locale/lt/LC_MESSAGES/gnome-keyring.mo
-share/locale/mn/LC_MESSAGES/gnome-keyring.mo
-share/locale/ms/LC_MESSAGES/gnome-keyring.mo
-share/locale/nb/LC_MESSAGES/gnome-keyring.mo
-share/locale/ne/LC_MESSAGES/gnome-keyring.mo
-share/locale/nl/LC_MESSAGES/gnome-keyring.mo
-share/locale/no/LC_MESSAGES/gnome-keyring.mo
-share/locale/pa/LC_MESSAGES/gnome-keyring.mo
-share/locale/pl/LC_MESSAGES/gnome-keyring.mo
-share/locale/pt/LC_MESSAGES/gnome-keyring.mo
-share/locale/pt_BR/LC_MESSAGES/gnome-keyring.mo
-share/locale/ro/LC_MESSAGES/gnome-keyring.mo
-share/locale/ru/LC_MESSAGES/gnome-keyring.mo
-share/locale/rw/LC_MESSAGES/gnome-keyring.mo
-share/locale/sk/LC_MESSAGES/gnome-keyring.mo
-share/locale/sq/LC_MESSAGES/gnome-keyring.mo
-share/locale/sr/LC_MESSAGES/gnome-keyring.mo
-share/locale/sr@Latn/LC_MESSAGES/gnome-keyring.mo
-share/locale/sv/LC_MESSAGES/gnome-keyring.mo
-share/locale/ta/LC_MESSAGES/gnome-keyring.mo
-share/locale/th/LC_MESSAGES/gnome-keyring.mo
-share/locale/tr/LC_MESSAGES/gnome-keyring.mo
-share/locale/uk/LC_MESSAGES/gnome-keyring.mo
-share/locale/xh/LC_MESSAGES/gnome-keyring.mo
-share/locale/zh_CN/LC_MESSAGES/gnome-keyring.mo
-share/locale/zh_HK/LC_MESSAGES/gnome-keyring.mo
-share/locale/zh_TW/LC_MESSAGES/gnome-keyring.mo
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrm include/gnome-keyring-1