aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg-devel
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnupg-devel')
-rw-r--r--security/gnupg-devel/Makefile58
-rw-r--r--security/gnupg-devel/distinfo2
-rw-r--r--security/gnupg-devel/files/patch-agent::Makefile.in11
-rw-r--r--security/gnupg-devel/files/patch-agent::gpg-agent.c12
-rw-r--r--security/gnupg-devel/files/patch-assuan::assuan-socket-connect.c10
-rw-r--r--security/gnupg-devel/files/patch-assuan::assuan-socket-server.c10
-rw-r--r--security/gnupg-devel/files/patch-configure.ac12
-rw-r--r--security/gnupg-devel/files/patch-kbx::Makefile.in11
-rw-r--r--security/gnupg-devel/files/patch-kbx::keybox-blob.c12
-rw-r--r--security/gnupg-devel/files/patch-kbx::keybox-dump.c10
-rw-r--r--security/gnupg-devel/files/patch-scd::Makefile.in11
-rw-r--r--security/gnupg-devel/files/patch-sm::Makefile.in11
-rw-r--r--security/gnupg-devel/pkg-descr6
-rw-r--r--security/gnupg-devel/pkg-plist7
14 files changed, 0 insertions, 183 deletions
diff --git a/security/gnupg-devel/Makefile b/security/gnupg-devel/Makefile
deleted file mode 100644
index c7dd8fa6812a..000000000000
--- a/security/gnupg-devel/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# New ports collection makefile for: newpg
-# Date created: 29 Jan 2003
-# Whom: michaelnottebrock@gmx.net
-#
-# $FreeBSD$
-#
-
-PORTNAME= newpg
-PORTVERSION= 0.9.4
-PORTREVISION= 4
-CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_GNUPG}
-MASTER_SITE_SUBDIR= alpha/aegypten
-
-MAINTAINER= lofi@freebsd.org
-COMMENT= Prerelease package of GnuPG extensions for GnuPG 2.0
-
-LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt \
- ksba.7:${PORTSDIR}/security/libksba \
- pth.20:${PORTSDIR}/devel/pth
-RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
- pinentry-curses:${PORTSDIR}/security/pinentry \
- dirmngr:${PORTSDIR}/security/dirmngr
-
-USE_AUTOCONF_VER=253
-USE_LIBTOOL_VER=13
-USE_GETTEXT= yes
-USE_GMAKE= yes
-USE_ICONV= yes
-INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
-CONFIGURE_ARGS+=--with-included-gettext=no
-INFO= gnupg
-
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/opensc-config)
-WITH_OPENSC= yes
-.endif
-
-.if defined(WITH_OPENSC)
-BUILD_DEPENDS+= opensc-config:${PORTSDIR}/security/opensc
-PLIST_SUB+= WITH_OPENSC=""
-.else
-CONFIGURE_ARGS+= --disable-scdaemon
-PLIST_SUB+= WITH_OPENSC="@comment "
-.endif
-
-pre-configure:
- ${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" \
- ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4 ${WRKSRC}/configure
- cd ${WRKSRC}; autoconf
-
-.include <bsd.port.post.mk>
diff --git a/security/gnupg-devel/distinfo b/security/gnupg-devel/distinfo
deleted file mode 100644
index 32f7143cee65..000000000000
--- a/security/gnupg-devel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (newpg-0.9.4.tar.gz) = 6b478f1ce8e37a55064ffc69b7325ea8
-SIZE (newpg-0.9.4.tar.gz) = 606811
diff --git a/security/gnupg-devel/files/patch-agent::Makefile.in b/security/gnupg-devel/files/patch-agent::Makefile.in
deleted file mode 100644
index df952017e8f2..000000000000
--- a/security/gnupg-devel/files/patch-agent::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- agent/Makefile.in Wed Dec 4 14:13:12 2002
-+++ agent/Makefile.in.new Wed Jan 29 19:37:03 2003
-@@ -137,7 +137,7 @@
- pkglib_PROGRAMS = gpg-protect-tool
-
- AM_CPPFLAGS = -I$(top_srcdir)/common $(LIBGCRYPT_CFLAGS) $(PTH_CFLAGS)
--LDFLAGS = @LDFLAGS@
-+LDFLAGS = @LDFLAGS@ $(INTLLIBS)
-
- gpg_agent_SOURCES = \
- gpg-agent.c agent.h \
diff --git a/security/gnupg-devel/files/patch-agent::gpg-agent.c b/security/gnupg-devel/files/patch-agent::gpg-agent.c
deleted file mode 100644
index 8d3871dce07a..000000000000
--- a/security/gnupg-devel/files/patch-agent::gpg-agent.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- agent/gpg-agent.c Wed Dec 4 13:08:25 2002
-+++ agent/gpg-agent.c.new Wed Jan 29 19:34:14 2003
-@@ -37,6 +37,9 @@
- # include <pth.h>
- #endif
-
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+
- #include <gcrypt.h>
-
- #define JNLIB_NEED_LOG_LOGV
diff --git a/security/gnupg-devel/files/patch-assuan::assuan-socket-connect.c b/security/gnupg-devel/files/patch-assuan::assuan-socket-connect.c
deleted file mode 100644
index 74acc38ea626..000000000000
--- a/security/gnupg-devel/files/patch-assuan::assuan-socket-connect.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- assuan/assuan-socket-connect.c.orig Wed Jan 29 15:30:12 2003
-+++ assuan/assuan-socket-connect.c Wed Jan 29 15:30:28 2003
-@@ -23,6 +23,7 @@
- #include <stddef.h>
- #include <stdio.h>
- #include <errno.h>
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/un.h>
- #include <unistd.h>
diff --git a/security/gnupg-devel/files/patch-assuan::assuan-socket-server.c b/security/gnupg-devel/files/patch-assuan::assuan-socket-server.c
deleted file mode 100644
index af8a39751c34..000000000000
--- a/security/gnupg-devel/files/patch-assuan::assuan-socket-server.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- assuan/assuan-socket-server.c.orig Wed Jan 29 15:27:13 2003
-+++ assuan/assuan-socket-server.c Wed Jan 29 15:27:38 2003
-@@ -22,6 +22,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <errno.h>
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/un.h>
- #include <unistd.h>
diff --git a/security/gnupg-devel/files/patch-configure.ac b/security/gnupg-devel/files/patch-configure.ac
deleted file mode 100644
index 00bdf48f7959..000000000000
--- a/security/gnupg-devel/files/patch-configure.ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.ac.orig Thu Jan 30 00:43:39 2003
-+++ configure.ac Thu Jan 30 00:44:25 2003
-@@ -303,7 +303,7 @@
- AC_REPLACE_FUNCS(mkdtemp)
- AC_REPLACE_FUNCS(fseeko ftello)
- AC_REPLACE_FUNCS(isascii)
--AC_REPLACE_FUNCS(putc_unlocked)
-+AC_DEFINE(HAVE_PUTC_UNLOCKED, 1, [FreeBSD has it, trust me])
-
- # We use jnlib, so tell other modules about it
- AC_DEFINE(HAVE_JNLIB_LOGGING, 1,
-
diff --git a/security/gnupg-devel/files/patch-kbx::Makefile.in b/security/gnupg-devel/files/patch-kbx::Makefile.in
deleted file mode 100644
index 8dbdaa51bef4..000000000000
--- a/security/gnupg-devel/files/patch-kbx::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- kbx/Makefile.in.orig Wed Jan 29 17:09:39 2003
-+++ kbx/Makefile.in Wed Jan 29 17:10:18 2003
-@@ -156,7 +156,7 @@
- libkeybox_a_SOURCES = $(common_sources)
-
- kbxutil_SOURCES = kbxutil.c $(common_sources)
--kbxutil_LDADD = ../jnlib/libjnlib.a $(KSBA_LIBS) $(LIBGCRYPT_LIBS)
-+kbxutil_LDADD = ../jnlib/libjnlib.a $(KSBA_LIBS) $(LIBGCRYPT_LIBS) $(INTLLIBS)
- subdir = kbx
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = $(top_builddir)/config.h
diff --git a/security/gnupg-devel/files/patch-kbx::keybox-blob.c b/security/gnupg-devel/files/patch-kbx::keybox-blob.c
deleted file mode 100644
index 44b70594b82b..000000000000
--- a/security/gnupg-devel/files/patch-kbx::keybox-blob.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- kbx/keybox-blob.c.orig Mon Jul 22 11:26:51 2002
-+++ kbx/keybox-blob.c Wed Jan 29 17:00:14 2003
-@@ -119,8 +119,8 @@
- #include <ksba.h>
- #endif
-
-+#include "../jnlib/types.h"
- #include "keybox-defs.h"
--
-
- /* special values of the signature status */
- #define SF_NONE(a) ( !(a) )
diff --git a/security/gnupg-devel/files/patch-kbx::keybox-dump.c b/security/gnupg-devel/files/patch-kbx::keybox-dump.c
deleted file mode 100644
index b165dd48f30c..000000000000
--- a/security/gnupg-devel/files/patch-kbx::keybox-dump.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- kbx/keybox-dump.c.orig Mon Jul 22 10:33:48 2002
-+++ kbx/keybox-dump.c Wed Jan 29 17:00:08 2003
-@@ -24,6 +24,7 @@
- #include <string.h>
- #include <errno.h>
-
-+#include "../jnlib/types.h"
- #include "keybox-defs.h"
-
- static ulong
diff --git a/security/gnupg-devel/files/patch-scd::Makefile.in b/security/gnupg-devel/files/patch-scd::Makefile.in
deleted file mode 100644
index 7d0202eedc3e..000000000000
--- a/security/gnupg-devel/files/patch-scd::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- scd/Makefile.in Wed Dec 4 14:13:18 2002
-+++ scd/Makefile.in.new Wed Jan 29 19:46:49 2003
-@@ -138,7 +138,7 @@
- AM_CPPFLAGS = -I$(top_srcdir)/common $(OPENSC_CFLAGS) $(LIBGCRYPT_CFLAGS) \
- $(KSBA_CFLAGS)
-
--LDFLAGS = @LDFLAGS@
-+LDFLAGS = @LDFLAGS@ $(INTLLIBS)
-
- scdaemon_SOURCES = \
- scdaemon.c scdaemon.h \
diff --git a/security/gnupg-devel/files/patch-sm::Makefile.in b/security/gnupg-devel/files/patch-sm::Makefile.in
deleted file mode 100644
index 0e5aa678b463..000000000000
--- a/security/gnupg-devel/files/patch-sm::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- sm/Makefile.in.orig Wed Jan 29 17:15:33 2003
-+++ sm/Makefile.in Wed Jan 29 17:15:59 2003
-@@ -165,7 +165,7 @@
-
-
- gpgsm_LDADD = ../jnlib/libjnlib.a ../assuan/libassuan.a ../kbx/libkeybox.a \
-- ../common/libcommon.a $(LIBGCRYPT_LIBS) $(KSBA_LIBS)
-+ ../common/libcommon.a $(LIBGCRYPT_LIBS) $(KSBA_LIBS) $(INTLLIBS)
-
- subdir = sm
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/security/gnupg-devel/pkg-descr b/security/gnupg-devel/pkg-descr
deleted file mode 100644
index 3c781779db46..000000000000
--- a/security/gnupg-devel/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-NewPG is a temporary protect to work on GnuPG extensions. It will
-be merged into the regular GnuPG sources for a GnuPG 2.0 release.
-
-WWW: http://www.gnupg.org/aegypten/
-
-michaelnottebrock@gmx.net
diff --git a/security/gnupg-devel/pkg-plist b/security/gnupg-devel/pkg-plist
deleted file mode 100644
index 39fe66c21124..000000000000
--- a/security/gnupg-devel/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/gpg-agent
-bin/gpgsm
-bin/kbxutil
-%%WITH_OPENSC%%bin/scdaemon
-lib/newpg/gpg-protect-tool
-share/locale/de/LC_MESSAGES/newpg.mo
-@dirrm lib/newpg