aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnutls-devel/Makefile')
-rw-r--r--security/gnutls-devel/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index 57a5577a8080..0eb89c8b41eb 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -50,15 +50,15 @@ PLIST_SUB+= CXX="@comment "
PLIST_SUB+= CXX=""
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= AUTHORS NEWS README THANKS
.endif
EXAMPLES= doc/examples/*.c
@@ -72,7 +72,7 @@ pre-configure:
post-install:
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}