aboutsummaryrefslogtreecommitdiff
path: root/security/go.crypto
diff options
context:
space:
mode:
Diffstat (limited to 'security/go.crypto')
-rw-r--r--security/go.crypto/Makefile23
-rw-r--r--security/go.crypto/distinfo4
-rw-r--r--security/go.crypto/pkg-plist66
3 files changed, 81 insertions, 12 deletions
diff --git a/security/go.crypto/Makefile b/security/go.crypto/Makefile
index d3fcedf9b8e7..cbcac6ce2ac4 100644
--- a/security/go.crypto/Makefile
+++ b/security/go.crypto/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: go.crypto
-# Date created: 2012-05-03
-# Whom: Julien Laffaye <jlaffaye@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= go.crypto
-PORTVERSION= 20120503
+PORTVERSION= 20121001
CATEGORIES= security devel
MASTER_SITES= http://jlaffaye.net/ LOCAL/jlaffaye
@@ -16,22 +11,32 @@ COMMENT= Additional cryptography packages for Go
GO_PKGNAME= code.google.com/p/go.crypto
GO_TARGET= ${GO_PKGNAME}/bcrypt \
${GO_PKGNAME}/blowfish \
+ ${GO_PKGNAME}/bn256 \
${GO_PKGNAME}/cast5 \
${GO_PKGNAME}/curve25519 \
${GO_PKGNAME}/md4 \
+ ${GO_PKGNAME}/nacl/box \
+ ${GO_PKGNAME}/nacl/secretbox \
${GO_PKGNAME}/ocsp \
${GO_PKGNAME}/openpgp \
+ ${GO_PKGNAME}/otr \
${GO_PKGNAME}/pbkdf2 \
+ ${GO_PKGNAME}/poly1305 \
${GO_PKGNAME}/ripemd160 \
+ ${GO_PKGNAME}/salsa20 \
+ ${GO_PKGNAME}/scrypt \
${GO_PKGNAME}/ssh \
${GO_PKGNAME}/twofish \
- ${GO_PKGNAME}/xtea
+ ${GO_PKGNAME}/xtea \
+ ${GO_PKGNAME}/xts
do-install:
${MKDIR} ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
+ (cd ${GO_WRKDIR_PKG}/ && ${COPYTREE_SHARE} \* \
+ ${GO_LOCAL_LIBDIR})
.for t in ${GO_TARGET}
- ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${t}.a \
- ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
+ #${INSTALL_DATA} ${GO_WRKDIR_PKG}/${t}.a \
+ # ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
${MKDIR} ${GO_LOCAL_SRCDIR}/${t}
(cd ${GO_WRKDIR_SRC}/${t}/ && ${COPYTREE_SHARE} \* \
${GO_LOCAL_SRCDIR}/${t})
diff --git a/security/go.crypto/distinfo b/security/go.crypto/distinfo
index e810994a6223..6db872962462 100644
--- a/security/go.crypto/distinfo
+++ b/security/go.crypto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (go.crypto-20120503.tar.gz) = e24c918468b772f14f5f5acea5fc22530960681deefcbee8df6a3efc40933635
-SIZE (go.crypto-20120503.tar.gz) = 174988
+SHA256 (go.crypto-20121001.tar.gz) = eda7f931041b17e4ce6757819f7fea87edf2c0371d5d360eabb31f9d929134d6
+SIZE (go.crypto-20121001.tar.gz) = 233879
diff --git a/security/go.crypto/pkg-plist b/security/go.crypto/pkg-plist
index aee99989f322..667814ff8cd8 100644
--- a/security/go.crypto/pkg-plist
+++ b/security/go.crypto/pkg-plist
@@ -1,16 +1,30 @@
@comment $FreeBSD$
%%GO_LIBDIR%%/%%GO_PKGNAME%%/bcrypt.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/blowfish.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/bn256.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/cast5.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/curve25519.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/md4.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/nacl/box.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/nacl/secretbox.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/ocsp.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/openpgp.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/openpgp/armor.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/openpgp/elgamal.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/openpgp/errors.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/openpgp/packet.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/openpgp/s2k.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/otr.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/pbkdf2.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/poly1305.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/ripemd160.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/salsa20.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/salsa20/salsa.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/scrypt.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/ssh.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/twofish.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/xtea.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/xts.a
%%GO_SRCDIR%%/%%GO_PKGNAME%%/bcrypt/base64.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/bcrypt/bcrypt.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/bcrypt/bcrypt_test.go
@@ -18,6 +32,16 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/blowfish/blowfish_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/blowfish/cipher.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/blowfish/const.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/bn256.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/bn256_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/constants.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/curve.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/example_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/gfp12.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/gfp2.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/gfp6.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/optate.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256/twist.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/cast5/cast5.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/cast5/cast5_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/curve25519/const_amd64.s
@@ -33,6 +57,10 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/md4/md4.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/md4/md4_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/md4/md4block.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nacl/box/box.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nacl/box/box_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nacl/secretbox/secretbox.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nacl/secretbox/secretbox_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ocsp/ocsp.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ocsp/ocsp_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/armor/armor.go
@@ -76,12 +104,34 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/s2k/s2k_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/write.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/write_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/otr/libotr_test_helper.c
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/otr/otr.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/otr/otr_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/otr/smp.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/pbkdf2/pbkdf2.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/pbkdf2/pbkdf2_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/const_amd64.s
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/poly1305.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/poly1305_amd64.s
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/poly1305_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/sum_amd64.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305/sum_ref.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ripemd160/ripemd160.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ripemd160/ripemd160_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ripemd160/ripemd160block.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa/hsalsa20.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa/salsa2020_amd64.s
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa/salsa208.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa/salsa20_amd64.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa/salsa20_ref.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa/salsa_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa20.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa20_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/scrypt/scrypt.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/scrypt/scrypt_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/agent.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/buffer.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/buffer_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/certs.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/channel.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/cipher.go
@@ -100,7 +150,6 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/messages_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/server.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/server_terminal.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/server_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/session.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/session_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/tcpip.go
@@ -115,15 +164,26 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/xtea/block.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/xtea/cipher.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/xtea/xtea_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/xts/xts.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/xts/xts_test.go
+@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%/salsa20
+@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%/openpgp
+@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%/nacl
@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%
@dirrmtry %%GO_LIBDIR%%/code.google.com/p
@dirrmtry %%GO_LIBDIR%%/code.google.com
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/xts
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/xtea
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/twofish
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/scrypt
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/ripemd160
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/poly1305
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/pbkdf2
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/otr
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/s2k
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/errors
@@ -132,9 +192,13 @@
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/armor
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/ocsp
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/nacl/secretbox
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/nacl/box
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/nacl
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/md4
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/curve25519
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/cast5
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/bn256
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/blowfish
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/bcrypt
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%