aboutsummaryrefslogtreecommitdiff
path: root/security/hostapd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hostapd/Makefile')
-rw-r--r--security/hostapd/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/hostapd/Makefile b/security/hostapd/Makefile
new file mode 100644
index 000000000000..51b0183277ca
--- /dev/null
+++ b/security/hostapd/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: hostapd
+# Date created: 7 December 2004
+# Whom: sam
+#
+# $FreeBSD$
+#
+
+PORTNAME= hostapd
+PORTVERSION= 0.3.0
+CATEGORIES= security
+MASTER_SITES= http://hostap.epitest.fi/releases/
+DISTNAME= hostapd-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Authenticator (server) for WPA/802.1x protocols
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_GMAKE= yes
+
+post-extract:
+ @${CP} ${FILESDIR}/config.bsd ${WRKSRC}/.config
+
+.include <bsd.port.mk>