aboutsummaryrefslogtreecommitdiff
path: root/security/hs-cprng-aes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-cprng-aes/Makefile')
-rw-r--r--security/hs-cprng-aes/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/security/hs-cprng-aes/Makefile b/security/hs-cprng-aes/Makefile
index 0ccca95a953b..b193b828259e 100644
--- a/security/hs-cprng-aes/Makefile
+++ b/security/hs-cprng-aes/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: hs-cprng-aes
-# Date created: December 2, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= cprng-aes
-PORTVERSION= 0.2.3
-PORTREVISION= 2
+PORTVERSION= 0.2.4
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -16,8 +10,8 @@ COMMENT= Crypto Pseudo Random Number Generator using AES
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= cereal>=0.3.0 crypto-api>=0.8 cryptocipher>=0.2.5 entropy>=0.2 \
- random
+USE_CABAL= cereal>=0.3.0 cipher-aes>=0.1 crypto-api>=0.8 cryptocipher \
+ entropy>=0.2 random
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>