aboutsummaryrefslogtreecommitdiff
path: root/security/hs-cprng-aes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-cprng-aes/Makefile')
-rw-r--r--security/hs-cprng-aes/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/security/hs-cprng-aes/Makefile b/security/hs-cprng-aes/Makefile
index 6e807b60f70b..78ca19f11626 100644
--- a/security/hs-cprng-aes/Makefile
+++ b/security/hs-cprng-aes/Makefile
@@ -1,17 +1,15 @@
# $FreeBSD$
PORTNAME= cprng-aes
-PORTVERSION= 0.3.4
-PORTREVISION= 6
+PORTVERSION= 0.5.2
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Crypto Pseudo Random Number Generator using AES
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-USE_CABAL= cipher-aes>=0.1 crypto-api>=0.8 crypto-random-api>=0.2 \
- entropy>=0.2 random
+USE_CABAL= byteable cipher-aes>=0.2 crypto-random>=0.0.7 random
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>