aboutsummaryrefslogtreecommitdiff
path: root/security/hs-cryptocipher/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-cryptocipher/Makefile')
-rw-r--r--security/hs-cryptocipher/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/security/hs-cryptocipher/Makefile b/security/hs-cryptocipher/Makefile
index 3f4c66223cd1..a21e1fc6d73a 100644
--- a/security/hs-cryptocipher/Makefile
+++ b/security/hs-cryptocipher/Makefile
@@ -1,17 +1,16 @@
# $FreeBSD$
PORTNAME= cryptocipher
-PORTVERSION= 0.5.0
-PORTREVISION= 4
+PORTVERSION= 0.6.2
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= Symmetrical Block, Stream, and PubKey Ciphers
+COMMENT= Symmetrical block and stream ciphers
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-USE_CABAL= cereal cipher-aes cipher-rc4 cpu>=0.1 crypto-api>=0.5 \
- primitive vector>=0.7
+USE_CABAL= cipher-aes>=0.2.3 cipher-blowfish>=0.0 cipher-camellia>=0.0 \
+ cipher-des>=0.0 cipher-rc4>=0.1.3 crypto-cipher-types>=0.0.8
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>