aboutsummaryrefslogtreecommitdiff
path: root/security/hs-tls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-tls/Makefile')
-rw-r--r--security/hs-tls/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/security/hs-tls/Makefile b/security/hs-tls/Makefile
index 6c306f08c5f4..799d80979f81 100644
--- a/security/hs-tls/Makefile
+++ b/security/hs-tls/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= tls
-PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTVERSION= 1.3.1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,11 +9,9 @@ COMMENT= TLS/SSL protocol native implementation (Server and Client)
LICENSE= BSD3CLAUSE
-USE_CABAL= asn1-encoding asn1-types>=0.2.0 byteable cereal>=0.4 \
- cipher-aes>=0.2 cipher-des cipher-rc4 crypto-cipher-types>=0.0.8 \
- crypto-numbers crypto-pubkey>=0.2.4 crypto-pubkey-types>=0.4 \
- crypto-random>=0.0 cryptohash>=0.6 data-default-class \
- mtl network x509>=1.4.3 x509-store>=1.4.4 x509-validation>=1.5.0
+USE_CABAL= asn1-encoding asn1-types>=0.2.0 async byteable cereal>=0.4 \
+ cryptonite>=0.3 data-default-class memory mtl network \
+ x509>=1.6 x509-store>=1.6 x509-validation>=1.6
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>