aboutsummaryrefslogtreecommitdiff
path: root/security/hs-tls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-tls/Makefile')
-rw-r--r--security/hs-tls/Makefile26
1 files changed, 3 insertions, 23 deletions
diff --git a/security/hs-tls/Makefile b/security/hs-tls/Makefile
index 510a2db20a54..1f7ec25ea6f5 100644
--- a/security/hs-tls/Makefile
+++ b/security/hs-tls/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: hs-tls
-# Date created: December 26, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= tls
-PORTVERSION= 0.9.5
-PORTREVISION= 1
+PORTVERSION= 1.0.2
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -17,22 +11,8 @@ LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= cereal>=0.3 certificate>=1.2.0 crypto-api>=0.5 \
- cryptocipher>=0.3.0 cryptohash>=0.6 mtl
-
-OPTIONS_DEFINE= EXECUTABLE
-
-EXECUTABLE_DESC= Build the executables
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXECUTABLE}
-CONFIGURE_ARGS+= --flags="executable"
-USE_CABAL+= cmdargs cprng-aes>=0.2.3 network
-EXECUTABLE+= stunnel checkciphers retrievecertificate simpleclient
-.else
-CONFIGURE_ARGS+= --flags="-executable"
-.endif
+USE_CABAL= cereal>=0.3 certificate>=1.3.0 crypto-api>=0.5 \
+ cryptocipher>=0.3.0 cryptohash>=0.6 mtl network
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>