aboutsummaryrefslogtreecommitdiff
path: root/security/hs-tls
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-tls')
-rw-r--r--security/hs-tls/Makefile26
-rw-r--r--security/hs-tls/distinfo4
-rw-r--r--security/hs-tls/pkg-descr16
3 files changed, 11 insertions, 35 deletions
diff --git a/security/hs-tls/Makefile b/security/hs-tls/Makefile
index 510a2db20a54..1f7ec25ea6f5 100644
--- a/security/hs-tls/Makefile
+++ b/security/hs-tls/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: hs-tls
-# Date created: December 26, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= tls
-PORTVERSION= 0.9.5
-PORTREVISION= 1
+PORTVERSION= 1.0.2
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -17,22 +11,8 @@ LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= cereal>=0.3 certificate>=1.2.0 crypto-api>=0.5 \
- cryptocipher>=0.3.0 cryptohash>=0.6 mtl
-
-OPTIONS_DEFINE= EXECUTABLE
-
-EXECUTABLE_DESC= Build the executables
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXECUTABLE}
-CONFIGURE_ARGS+= --flags="executable"
-USE_CABAL+= cmdargs cprng-aes>=0.2.3 network
-EXECUTABLE+= stunnel checkciphers retrievecertificate simpleclient
-.else
-CONFIGURE_ARGS+= --flags="-executable"
-.endif
+USE_CABAL= cereal>=0.3 certificate>=1.3.0 crypto-api>=0.5 \
+ cryptocipher>=0.3.0 cryptohash>=0.6 mtl network
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-tls/distinfo b/security/hs-tls/distinfo
index dae33b41c938..2e8b794a94c2 100644
--- a/security/hs-tls/distinfo
+++ b/security/hs-tls/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/tls-0.9.5.tar.gz) = be446af7097014e4827fbff80df7d607a4b3322d1ce69586b08694d87d8d6ed9
-SIZE (cabal/tls-0.9.5.tar.gz) = 32807
+SHA256 (cabal/tls-1.0.2.tar.gz) = e55472857aea73a4ea719604c983dcb0c3e31beb0aa10d0bc1fc3e2213826b3a
+SIZE (cabal/tls-1.0.2.tar.gz) = 46390
diff --git a/security/hs-tls/pkg-descr b/security/hs-tls/pkg-descr
index acdf7dfc3426..b7cd3db8b79c 100644
--- a/security/hs-tls/pkg-descr
+++ b/security/hs-tls/pkg-descr
@@ -1,12 +1,8 @@
Native Haskell TLS and SSL protocol implementation for server and
-client.
+client. This provides a high-level implementation of a sensitive
+security protocol, eliminating a common set of security issues through
+the use of the advanced type system, high level constructions and common
+Haskell features. Currently implement the SSL3.0, TLS1.0, TLS1.1 and
+TLS1.2 protocol, with only RSA supported for Key Exchange.
-This provides a high-level implementation of a sensitive security
-protocol, eliminating a common set of security issues through the use of
-the advanced type system, high level constructions and common Haskell
-features.
-
-Currently implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, with
-only RSA supported for Key Exchange.
-
-WWW: http://github.com/vincenthz/hs-tls
+WWW: http://github.com/vincenthz/hs-tls