aboutsummaryrefslogtreecommitdiff
path: root/security/hs-x509-validation/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-x509-validation/Makefile')
-rw-r--r--security/hs-x509-validation/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/security/hs-x509-validation/Makefile b/security/hs-x509-validation/Makefile
index 260c6c581a10..ece75bc58fa6 100644
--- a/security/hs-x509-validation/Makefile
+++ b/security/hs-x509-validation/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= x509-validation
-PORTVERSION= 1.5.0
-PORTREVISION= 1
+PORTVERSION= 1.6.0
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,9 +9,9 @@ COMMENT= X.509 Certificate and CRL validation
LICENSE= BSD3CLAUSE
-USE_CABAL= asn1-encoding>=0.8 asn1-types>=0.2 byteable crypto-pubkey>=0.1.4 \
- crypto-pubkey-types>=0.4 cryptohash>=0.9 data-default-class \
- mtl network pem>=0.1 x509>=1.4.7 x509-store>=1.4
+USE_CABAL= asn1-encoding>=0.9 asn1-types>=0.3 byteable cryptonite>=0.3 \
+ data-default-class hourglass memory mtl network pem>=0.1 \
+ x509>=1.6 x509-store>=1.6
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>