aboutsummaryrefslogtreecommitdiff
path: root/security/hunch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hunch/Makefile')
-rw-r--r--security/hunch/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/hunch/Makefile b/security/hunch/Makefile
new file mode 100644
index 000000000000..a38d2535da68
--- /dev/null
+++ b/security/hunch/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hunch
+# Date created: 26 October 2002
+# Whom: Dan Pelleg <daniel+hunch@pelleg.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hunch
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://web.cs.cmu.edu/~dpelleg/download/
+
+MAINTAINER= daniel+hunch@pelleg.org
+COMMENT= Scan httpd log files, find vulnerability probes, mail admins
+
+RUN_DEPENDS= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+
+IS_INTERACTIVE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+NO_PACKAGE= too interactive
+NO_BUILD= true
+USE_PERL5= YES
+
+do-install:
+ @${ECHO_MSG} "Installing files"
+ @${INSTALL_DATA} ${WRKSRC}/etc/hunch-special ${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/complain-httpd ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/contact ${PREFIX}/bin
+
+post-install:
+ @PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>