aboutsummaryrefslogtreecommitdiff
path: root/security/hydra
diff options
context:
space:
mode:
Diffstat (limited to 'security/hydra')
-rw-r--r--security/hydra/Makefile5
-rw-r--r--security/hydra/distinfo4
-rw-r--r--security/hydra/files/patch-printf16
-rw-r--r--security/hydra/files/patch-smbnt32
4 files changed, 5 insertions, 52 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index d896866d5e9f..f133823e1520 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -7,12 +7,12 @@
#
PORTNAME= hydra
-PORTVERSION= 4.0
+PORTVERSION= 4.5
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/ \
${MASTER_SITE_PACKETSTORM}
-EXTRACT_SUFX= -src.tar.gz
MASTER_SITE_SUBDIR= groups/thc
+EXTRACT_SUFX= -src.tar.gz
MAINTAINER= llevier@argosnet.com
COMMENT= Brute force attack utility working on multiple network services
@@ -22,6 +22,7 @@ PLIST_FILES= bin/hydra
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
post-patch:
@${REINPLACE_CMD} -e 's|CC = gcc||; \
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
index 642b6115fd44..72e8c4a52781 100644
--- a/security/hydra/distinfo
+++ b/security/hydra/distinfo
@@ -1,2 +1,2 @@
-MD5 (hydra-4.0-src.tar.gz) = 858e0b049fed9dcf06c7c8d052579f69
-SIZE (hydra-4.0-src.tar.gz) = 82558
+MD5 (hydra-4.5-src.tar.gz) = 04c45be0ded184d0f7e92c7a4a936f82
+SIZE (hydra-4.5-src.tar.gz) = 166724
diff --git a/security/hydra/files/patch-printf b/security/hydra/files/patch-printf
deleted file mode 100644
index dd94734267b5..000000000000
--- a/security/hydra/files/patch-printf
+++ /dev/null
@@ -1,16 +0,0 @@
---- hydra.c Fri Apr 16 11:37:13 2004
-+++ hydra.c Mon May 3 15:43:51 2004
-@@ -215,5 +215,5 @@
- return;
-
-- printf("[DEBUG] Code: %s Time: %lu\n", string, time(NULL));
-+ printf("[DEBUG] Code: %s Time: %lu\n", string, (long unsigned)time(NULL));
- printf("[DEBUG] Options: mode %d ssl %d restore %d showAttempt %d tasks %d tnp %d tpsal %d exit_found %d miscptr %s service %s\n",
- hydra_options.mode, hydra_options.ssl, hydra_options.restore, hydra_options.showAttempt, hydra_options.tasks,
-@@ -1608,5 +1608,5 @@
- if ((hydra_brains.todo_all - hydra_brains.sent) / (hydra_brains.sent / (elapsed_status - starttime)) < 150)
- status_print = 59;
-- printf("[STATUS] %.2f tries/min, %lu tries in %02lu:%02luh, %lu todo in %02lu:%02luh\n",
-+ printf("[STATUS] %.2f tries/min, %lu tries in %02d:%02dh, %lu todo in %02lu:%02luh\n",
- (1.0 * hydra_brains.sent) / (((elapsed_status - starttime) * 1.0) / 60), hydra_brains.sent, (elapsed_status - starttime) / 3600,
- ((elapsed_status - starttime) % 3600) / 60, hydra_brains.todo_all - hydra_brains.sent,
diff --git a/security/hydra/files/patch-smbnt b/security/hydra/files/patch-smbnt
deleted file mode 100644
index e59af5aa7e6d..000000000000
--- a/security/hydra/files/patch-smbnt
+++ /dev/null
@@ -1,32 +0,0 @@
---- configure Thu Nov 20 10:45:28 2003
-+++ configure Mon May 3 15:14:26 2004
-@@ -26,5 +26,5 @@
- LIBDIRS=`cat /etc/ld.so.conf 2> /dev/null`
- PREFIX=`echo "$1"|sed 's/.*--prefix=//'`
--LIBDES=""
-+LIBDES=" "
- echo
-
---- hydra-smbnt.c Fri Dec 12 03:47:16 2003
-+++ hydra-smbnt.c Mon May 3 15:19:09 2004
-@@ -5,6 +5,7 @@
- }
- #else
--#include "md4.h"
--#include <des.h>
-+#include <openssl/md4.h>
-+#include <openssl/des.h>
-+#include <openssl/des_old.h>
-
- /*
-@@ -132,7 +132,7 @@
- unicodePassword[i * 2] = (u_char)pass[i];
-
-- MD4Init(&md4Context);
-- MD4Update(&md4Context, unicodePassword, mdlen);
-- MD4Final(hash, &md4Context); /* Tell MD4 we're done */
-+ MD4_Init(&md4Context);
-+ MD4_Update(&md4Context, unicodePassword, mdlen);
-+ MD4_Final(hash, &md4Context); /* Tell MD4 we're done */
- }
-