aboutsummaryrefslogtreecommitdiff
path: root/security/ifd-slb_rf60/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ifd-slb_rf60/Makefile')
-rw-r--r--security/ifd-slb_rf60/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/security/ifd-slb_rf60/Makefile b/security/ifd-slb_rf60/Makefile
new file mode 100644
index 000000000000..7ff82dd2804f
--- /dev/null
+++ b/security/ifd-slb_rf60/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: slb_rf60
+# Date created: 20 Feb 2003
+# Whom: Toni Andjelkovic <toni@soth.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ifd-slb_rf60
+PORTVERSION= 2.2.0
+CATEGORIES= security devel
+MASTER_SITES= http://www.linuxnet.com/drivers/readers/files/
+DISTNAME= ${PORTNAME:S/^ifd-//}-drv-${PORTVERSION}
+
+MAINTAINER= toni@soth.at
+COMMENT= PC/SC Lite driver for the Reflex 62 serial smart card reader
+
+LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+
+USE_GMAKE= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^ifd-//}
+
+PORTDOCS= README
+PLIST_FILES= pcsc/drivers/libslb_rf60.so
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libslb_rf60.so \
+ ${PREFIX}/pcsc/drivers/libslb_rf60.so
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${SED} 's,%%PREFIX%%,${PREFIX},g' < ${FILESDIR}/pkg-message.in > \
+ ${WRKDIR}/pkg-message
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>