aboutsummaryrefslogtreecommitdiff
path: root/security/l0phtcrack/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/l0phtcrack/Makefile')
-rw-r--r--security/l0phtcrack/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/security/l0phtcrack/Makefile b/security/l0phtcrack/Makefile
new file mode 100644
index 000000000000..9853f2abfe3f
--- /dev/null
+++ b/security/l0phtcrack/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: l0phtcrack
+# Date created: 2000-10-31
+# Whom: Trevor Johnson
+#
+# $FreeBSD$
+#
+
+PORTNAME= l0phtcrack
+PORTVERSION= 1.5
+CATEGORIES= security
+MASTER_SITES= http://www.l0pht.com/l0phtcrack/dist/
+DISTNAME= lcsrc
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= trevor@FreeBSD.org
+
+DOCDIR= share/doc/${PORTNAME}
+NO_PACKAGE= "uses GNU getopt with BSDish-licensed code from OpenSSL"
+NO_WRKSUBDIR= yes
+PLIST= ${WRKDIR}/pkg-plist
+USE_ZIP= yes
+
+post-extract:
+ ${RM} ${WRKDIR}/*exe
+ ${PERL} -pi -e "s:\r::g" ${WRKDIR}/*
+ ${PERL} -pi -e "s:ommited:omitted:g" ${WRKDIR}/util.c
+
+do-build:
+ cd ${WRKDIR} && ${CC} ${CFLAGS} -DMPU8086 *.c -o lc_CLI
+
+pre-install:
+ ${ECHO} bin/lc_CLI > ${PLIST}
+.if !defined(NOPORTDOCS)
+ for i in `find ${WRKDIR} -name '*txt'`; \
+ do ${ECHO} ${DOCDIR}/`${BASENAME} $${i}` >> ${PLIST}; \
+ done
+ ${ECHO} @dirrm ${DOCDIR} >> ${PLIST}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lc_CLI ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${DOCDIR}
+ cd ${WRKSRC} && pax -r -w *txt ${PREFIX}/${DOCDIR}
+.endif
+
+.include <bsd.port.mk>