aboutsummaryrefslogtreecommitdiff
path: root/security/lasso/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/lasso/Makefile')
-rw-r--r--security/lasso/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
new file mode 100644
index 000000000000..6eaab3f56b36
--- /dev/null
+++ b/security/lasso/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: lasso
+# Date created: 2007-07-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lasso
+PORTVERSION= 2.0.0
+CATEGORIES= security
+MASTER_SITES= http://labs.libre-entreprise.org/frs/download.php/520/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Free Liberty Alliance Implementation
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= xmlsec1:${PORTSDIR}/security/xmlsec1
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+CONFIGURE_ARGS+= --disable-java --disable-php4 --with-zlib
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack glib20
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+USE_PYTHON= yes
+
+.ifdef(WITH_PERL)
+CONFIGURE_ARGS+= --enable-perl
+PLIST_SUB+= WITH_PERL=""
+USE_PERL5= yes
+.else
+CONFIGURE_ARGS+= --disable-perl
+PLIST_SUB+= WITH_PERL="@comment "
+.endif
+
+#.ifdef(WITH_PHP5)
+#CONFIGURE_ARGS+= --enable-php5 \
+# --with-php5-config="${LOCALBASE}/bin/php-config" \
+# --with-php5-extension-dir="${PREFIX}/lib/php/${PHP_EXT_DIR}"
+#IGNORE_WITH_PHP= 4
+#PLIST_SUB+= WITH_PHP5=""
+#USE_PHP= yes
+#.else
+CONFIGURE_ARGS+= --disable-php5
+PLIST_SUB+= WITH_PHP5="@comment "
+#.endif
+
+.ifdef(WITH_PYTHON)
+CONFIGURE_ARGS+= --enable-python
+PLIST_SUB+= WITH_PYTHON=""
+.else
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= WITH_PYTHON="@comment "
+.endif
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod
+.ifdef(NOPORTDOCS)
+ ${RM} -rf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>