aboutsummaryrefslogtreecommitdiff
path: root/security/md5coll/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/md5coll/Makefile')
-rw-r--r--security/md5coll/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/md5coll/Makefile b/security/md5coll/Makefile
new file mode 100644
index 000000000000..047422f41c3b
--- /dev/null
+++ b/security/md5coll/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: md5 collision generator
+# Date created: Wed Nov 23 04:51:32 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= md5coll
+DISTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= http://www.stachliu.com/
+DISTNAME= ${PORTNAME}.c
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Fast MD5 collision generator
+
+ONLY_FOR_ARCHS= i386
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/${DISTNAME} -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>