aboutsummaryrefslogtreecommitdiff
path: root/security/metasploit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/metasploit/Makefile')
-rw-r--r--security/metasploit/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index df88037a9d82..e01daa718b6b 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= metasploit
-PORTVERSION= 4.16.32
+PORTVERSION= 4.16.36
CATEGORIES= security
MAINTAINER= tanawts@gmail.com
@@ -26,8 +26,8 @@ RUN_DEPENDS= nmap:security/nmap \
rubygem-metasploit-credential>=0:security/rubygem-metasploit-credential \
rubygem-metasploit_data_models>=0:security/rubygem-metasploit_data_models \
rubygem-metasploit-model>=0:security/rubygem-metasploit-model \
- rubygem-metasploit-payloads>=1.3.25:security/rubygem-metasploit-payloads \
- rubygem-metasploit_payloads-mettle>=0.3.3:security/rubygem-metasploit_payloads-mettle \
+ rubygem-metasploit-payloads>=1.3.28:security/rubygem-metasploit-payloads \
+ rubygem-metasploit_payloads-mettle>=0.3.6:security/rubygem-metasploit_payloads-mettle \
rubygem-msgpack1>=0:devel/rubygem-msgpack1 \
rubygem-network_interface>=0:net/rubygem-network_interface \
rubygem-rubyntlm>=0:net/rubygem-rubyntlm \
@@ -90,7 +90,9 @@ STRIP=
USES= python:env shebangfix
USE_RUBY= yes
-SHEBANG_FILES= data/exploits/CVE-2017-7494/build.sh \
+SHEBANG_FILES= data/exploits/CVE-2017-17562/build.sh \
+ data/exploits/CVE-2017-17562/install-deps.sh \
+ data/exploits/CVE-2017-7494/build.sh \
data/exploits/CVE-2017-7494/install-deps.sh \
external/source/shellcode/windows/build.sh \
external/source/msfJavaToolkit/compile.sh \
@@ -100,6 +102,7 @@ SHEBANG_FILES= data/exploits/CVE-2017-7494/build.sh \
docker/bin/msfvenom \
docker/bin/msfconsole \
modules/auxiliary/dos/http/slowloris.py \
+ modules/auxiliary/scanner/wproxy/att_open_proxy.py \
tools/hardware/killerbee_msfrelay \
tools/dev/import-dev-keys.sh \
tools/dev/sign-dev-keys.sh