aboutsummaryrefslogtreecommitdiff
path: root/security/mussh
diff options
context:
space:
mode:
Diffstat (limited to 'security/mussh')
-rw-r--r--security/mussh/Makefile35
-rw-r--r--security/mussh/distinfo1
-rw-r--r--security/mussh/pkg-comment1
-rw-r--r--security/mussh/pkg-descr6
-rw-r--r--security/mussh/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/security/mussh/Makefile b/security/mussh/Makefile
new file mode 100644
index 000000000000..899909ef60e4
--- /dev/null
+++ b/security/mussh/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mussh
+# Date created: 24 January 2002
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mussh
+PORTVERSION= 0.4
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= leeym@leeym.com
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,^#!/bin/bash,#!${LOCALBASE}/bin/bash,g" \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in CHANGES EXAMPLES README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/mussh/distinfo b/security/mussh/distinfo
new file mode 100644
index 000000000000..7223604d97fc
--- /dev/null
+++ b/security/mussh/distinfo
@@ -0,0 +1 @@
+MD5 (mussh-0.4.tgz) = 6e4d0f125470b882c81806a80e6f88a0
diff --git a/security/mussh/pkg-comment b/security/mussh/pkg-comment
new file mode 100644
index 000000000000..20d52a9134ee
--- /dev/null
+++ b/security/mussh/pkg-comment
@@ -0,0 +1 @@
+A tool for easily running the same commands on multiple hosts
diff --git a/security/mussh/pkg-descr b/security/mussh/pkg-descr
new file mode 100644
index 000000000000..4d1af1b8ac61
--- /dev/null
+++ b/security/mussh/pkg-descr
@@ -0,0 +1,6 @@
+Mussh is a shell script that allows you to execute a command or script
+over ssh on multiple hosts with one command. When possible mussh will use
+ssh-agent and RSA/DSA keys to minimize the need to enter your password
+more than once.
+
+WWW: http://sourceforge.net/projects/mussh/
diff --git a/security/mussh/pkg-plist b/security/mussh/pkg-plist
new file mode 100644
index 000000000000..7b643b68dff1
--- /dev/null
+++ b/security/mussh/pkg-plist
@@ -0,0 +1,5 @@
+bin/mussh
+%%PORTDOCS%%share/doc/mussh/CHANGES
+%%PORTDOCS%%share/doc/mussh/EXAMPLES
+%%PORTDOCS%%share/doc/mussh/README
+%%PORTDOCS%%@dirrm share/doc/mussh