aboutsummaryrefslogtreecommitdiff
path: root/security/nettle/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/nettle/Makefile')
-rw-r--r--security/nettle/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 7ae7ed67bd29..98ba631471b8 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= nettle
-PORTVERSION= 3.6
+PORTVERSION= 3.7.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= GNU \
https://www.lysator.liu.se/~nisse/archive/
@@ -23,14 +24,16 @@ USES= compiler:c11 gmake localbase makeinfo pathfix
CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= M4="/usr/bin/m4 -g"
GNU_CONFIGURE= yes
+TEST_TARGET= check
USE_LDCONFIG= yes
INFO= nettle
-PORTDOCS= NEWS README nettle.html nettle.pdf
-PORTEXAMPLES= *.c *.h
OPTIONS_DEFINE= DOCS EXAMPLES
+EXAMPLES_CFLAGS= -I${OPENSSLINC}
+EXAMPLES_USES= ssl
+
.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
@@ -43,15 +46,19 @@ post-patch:
@${REINPLACE_CMD} -e 's|__sgi|__unix__|' ${WRKSRC}/configure
.endif
+post-patch-EXAMPLES-off:
+ @${REINPLACE_CMD} -e '/SUBDIRS = / s| examples||' ${WRKSRC}/Makefile.in
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so
post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} NEWS README nettle.html nettle.pdf ${STAGEDIR}${DOCSDIR}
post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_PROGRAM} base16dec base16enc base64dec base64enc ecc-benchmark hogweed-benchmark nettle-benchmark random-prime rsa-decrypt rsa-encrypt rsa-keygen rsa-sign rsa-verify ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.[ch] ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>