aboutsummaryrefslogtreecommitdiff
path: root/security/nettle2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/nettle2/Makefile')
-rw-r--r--security/nettle2/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/security/nettle2/Makefile b/security/nettle2/Makefile
index f6fb3929b209..40f0c810b755 100644
--- a/security/nettle2/Makefile
+++ b/security/nettle2/Makefile
@@ -8,6 +8,7 @@
PORTNAME= nettle
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.lysator.liu.se/~nisse/archive/ \
ftp://ftp.lysator.liu.se/pub/security/lsh/
@@ -20,12 +21,25 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- MAKEINFO="makeinfo --no-split"
+CONFIGURE_ARGS= --enable-shared
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALLS_SHLIB= yes
+
+DOCS= NEWS README TODO nettle.html
+EXAMPLES= examples/README examples/*.c examples/*.h
+INFO= nettle
post-extract:
@${RM} -f ${WRKSRC}/nettle.info*
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>