aboutsummaryrefslogtreecommitdiff
path: root/security/ngrok/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ngrok/Makefile')
-rw-r--r--security/ngrok/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/security/ngrok/Makefile b/security/ngrok/Makefile
index dfaf583a6614..b66dfbe57e56 100644
--- a/security/ngrok/Makefile
+++ b/security/ngrok/Makefile
@@ -3,27 +3,28 @@
PORTNAME= ngrok
PORTVERSION= 2.2.8
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= https://bin.equinox.io/c/4VmDzA7iaHb/
-DISTNAME= ${PORTNAME}-stable-freebsd-${ARCH:S/i386/386/:S/x86_64/amd64/}
+MASTER_SITES= https://bin.equinox.io/a/${ARCH:S/i386/${i386_HASH}/:S/amd64/${amd64_HASH}/}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd-${ARCH:S/i386/386/}
DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= jhixson@FreeBSD.org
COMMENT= Secure tunnels to localhost
-BROKEN= unfetchable
-
# run 'ngrok credits' for details
LICENSE= NONE APACHE20 BSD3CLAUSE CC0-1.0 LGPL3+ MIT
LICENSE_COMB= multi
ONLY_FOR_ARCHS= amd64 i386
+i386_HASH= jsV5s66bZvF
+amd64_HASH= b8MLqEs7iBz
+
NO_WRKSUBDIR= yes
PLIST_FILES= bin/ngrok
NO_BUILD= yes
-USES= zip
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin