aboutsummaryrefslogtreecommitdiff
path: root/security/opencdk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/opencdk/Makefile')
-rw-r--r--security/opencdk/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index aec7b726e52f..2c4a83070175 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= opencdk
-PORTVERSION= 0.4.5
+PORTVERSION= 0.5.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
@@ -19,13 +19,15 @@ COMMENT= Open Crypto Development Kit
LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
+USE_BZIP2= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
USE_REINPLACE= yes
-DOCS= AUTHORS NEWS README THANKS
+DOCS= AUTHORS NEWS README THANKS doc/opencdk-api.html
+EXAMPLES= tests/*.c tests/*.gpg
post-patch:
.for file in encrypt.c main.c misc.c
@@ -34,14 +36,10 @@ post-patch:
post-install:
@${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/tests/*.c ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/tests/*.gpg ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/opencdk-api.html ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>