aboutsummaryrefslogtreecommitdiff
path: root/security/opencdk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/opencdk/Makefile')
-rw-r--r--security/opencdk/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index f5df7dc31385..62b4d10e45b6 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= opencdk
-PORTVERSION= 0.4.5
+PORTVERSION= 0.5.4
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG} \
@@ -18,7 +18,7 @@ MASTER_SITE_SUBDIR= alpha/gnutls/opencdk
MAINTAINER= sergei@FreeBSD.org
COMMENT= Open Crypto Development Kit
-LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.10:${PORTSDIR}/security/libgcrypt-devel
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -26,11 +26,11 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
USE_REINPLACE= yes
-DOCS= AUTHORS NEWS README THANKS
+DOCS= AUTHORS NEWS README THANKS doc/opencdk-api.html
post-patch:
-.for file in encrypt.c main.c misc.c
- ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/src/${file}
+.for f in encrypt.c main.c misc.c
+ ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/src/${f}
.endfor
post-install:
@@ -39,10 +39,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/tests/*.gpg ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/opencdk-api.html ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>