aboutsummaryrefslogtreecommitdiff
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 86b9fb9846e8..76e44e409677 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
DIST_SUBDIR= ${DISTNAME}
-MAINTAINER= dinoex@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= SSL and crypto library
LICENSE= OpenSSL
@@ -21,7 +21,7 @@ CONFLICTS= libressl-[0-9]* \
libressl-devel-[0-9]* \
openssl-devel-[0-9]*
-OPTIONS_DEFINE= SHARED THREADS SSE2 PADLOCK ZLIB SCTP SSL2 SSL3 RFC3779 MD2 RC5 EXPCIPHERS DOCS MAN3
+OPTIONS_DEFINE= SHARED THREADS SSE2 ASM PADLOCK ZLIB SCTP SSL2 SSL3 RFC3779 MD2 RC5 EXPCIPHERS DOCS MAN3
OPTIONS_DEFAULT=SHARED THREADS SSE2 SCTP SSL2 SSL3 MD2 MAN3
OPTIONS_DEFINE_i386= I386
OPTIONS_DEFINE_amd64= EC
@@ -36,6 +36,7 @@ OPTIONS_DEFAULT_mips= EC
NO_OPTIONS_SORT=yes
OPTIONS_SUB= yes
I386_DESC?= Optimize for i386 (instead of i486+)
+ASM_DESC?= optimized Assembler code
SSE2_DESC?= runtime SSE2 detection
PADLOCK_DESC?= VIA Padlock support
SHARED_DESC?= build of shared libs
@@ -82,7 +83,11 @@ EXTRACONFIGURE+= 386
EXTRACONFIGURE+= no-sse2
.endif
+.if ${PORT_OPTIONS:MASM}
+BROKEN_sparc64= option ASM generates illegal instructions
+.else
EXTRACONFIGURE+= no-asm
+.endif
.if ${PORT_OPTIONS:MTHREADS}
EXTRACONFIGURE+= threads