aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile4
-rw-r--r--security/openssl/distinfo4
-rw-r--r--security/openssl/files/patch-evp.h14
-rw-r--r--security/openssl/files/patch-hmac.h14
4 files changed, 4 insertions, 32 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index f8dfd6293099..142ceaf4f064 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -19,8 +19,8 @@ PORTVERSION= 0.9.8
PORTREVISION!= date -v-1d +%Y%m%d
.else
.if !defined(WITH_OPENSSL_BETA) && ( defined(WITH_OPENSSL_097) || defined(WITH_OPENSSL_STABLE) )
-PORTVERSION= 0.9.7h
-PORTREVISION?= 1
+PORTVERSION= 0.9.7i
+PORTREVISION?= 0
.else
PORTVERSION= 0.9.8a
PORTREVISION?= 0
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index a3589ff62d0b..eca63e21b5c9 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1,4 +1,4 @@
-MD5 (openssl-0.9.7h.tar.gz) = 8dc90a113eb8925795071fbe52b2932c
-SIZE (openssl-0.9.7h.tar.gz) = 3287019
MD5 (openssl-0.9.8a.tar.gz) = 1d16c727c10185e4d694f87f5e424ee1
SIZE (openssl-0.9.8a.tar.gz) = 3271435
+MD5 (openssl-0.9.7i.tar.gz) = f69d82b206ff8bff9d0e721f97380b9e
+SIZE (openssl-0.9.7i.tar.gz) = 3280907
diff --git a/security/openssl/files/patch-evp.h b/security/openssl/files/patch-evp.h
deleted file mode 100644
index dabadea299e4..000000000000
--- a/security/openssl/files/patch-evp.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- crypto/evp/evp.h.orig Thu Oct 13 17:24:41 2005
-+++ crypto/evp/evp.h Thu Oct 13 17:26:32 2005
-@@ -132,7 +132,11 @@
- #define EVP_CAST5_KEY_SIZE 16
- #define EVP_RC5_32_12_16_KEY_SIZE 16
- */
-+#ifdef OPENSSL_FIPS
- #define EVP_MAX_MD_SIZE 64 /* longest known SHA512 */
-+#else
-+#define EVP_MAX_MD_SIZE (16+20) /* The SSLv3 md5+sha1 type */
-+#endif
- #define EVP_MAX_KEY_LENGTH 32
- #define EVP_MAX_IV_LENGTH 16
- #define EVP_MAX_BLOCK_LENGTH 32
diff --git a/security/openssl/files/patch-hmac.h b/security/openssl/files/patch-hmac.h
deleted file mode 100644
index dab469e67b67..000000000000
--- a/security/openssl/files/patch-hmac.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- crypto/hmac/hmac.h.orig Thu Oct 13 17:27:32 2005
-+++ crypto/hmac/hmac.h Thu Oct 13 17:28:43 2005
-@@ -64,7 +64,11 @@
-
- #include <openssl/evp.h>
-
-+#ifdef OPENSSL_FIPS
- #define HMAC_MAX_MD_CBLOCK 128
-+#else
-+#define HMAC_MAX_MD_CBLOCK 64
-+#endif
-
- #ifdef __cplusplus
- extern "C" {