aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/openvpn-devel/Makefile')
-rw-r--r--security/openvpn-devel/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index 7b4ba71b9d16..0f795a4b153e 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -1,12 +1,12 @@
# Created by: Matthias Andree <mandree@FreeBSD.org>
# $FreeBSD$
-PORTNAME= openvpn
-DISTVERSION= 201652
+PORTNAME= openvpn
+DISTVERSION= 201719
PORTREVISION?= 0
-CATEGORIES= security net
+CATEGORIES= security net
MASTER_SITES= https://secure-computing.net/files/openvpn/ \
- ftp://ftp2.secure-computing.net/pub/FreeBSD/openvpn-devel/
+ ftp://ftp2.secure-computing.net/pub/FreeBSD/openvpn-devel/
PKGNAMESUFFIX= -devel
MAINTAINER= ecrist@secure-computing.net
@@ -17,11 +17,11 @@ LICENSE= GPLv2
CONFLICTS_INSTALL= openvpn-2.[!4].* openvpn-[!2].* openvpn-beta-[0-9]*
GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}
-USES= cpe libtool pkgconfig shebangfix tar:xz
+WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}
+USES= cpe libtool pkgconfig shebangfix tar:xz
SHEBANG_FILES= sample/sample-scripts/verify-cn \
- sample/sample-scripts/auth-pam.pl \
- sample/sample-scripts/ucn.pl
+ sample/sample-scripts/auth-pam.pl \
+ sample/sample-scripts/ucn.pl
CONFIGURE_ARGS+= --enable-strict
# avoid picking up CMAKE, we don't have cmocka in the tarballs..
CONFIGURE_ENV+= ac_cv_prog_CMAKE= CMAKE=
@@ -35,13 +35,14 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -DPLUGIN_LIBDIR=\\\"${PREFIX}/lib/openvpn/plugins\\\"
OPTIONS_DEFINE= PKCS11 EASYRSA DOCS EXAMPLES X509ALTUSERNAME \
- TEST LZ4 SMALL
+ TEST LZ4 SMALL TUNNELBLICK
OPTIONS_DEFAULT= EASYRSA OPENSSL TEST LZ4
OPTIONS_SINGLE= SSL
OPTIONS_SINGLE_SSL= OPENSSL MBEDTLS
PKCS11_DESC= Use security/pkcs11-helper
EASYRSA_DESC= Install security/easy-rsa RSA helper package
MBEDTLS_DESC= SSL/TLS via mbedTLS
+TUNNELBLICK_DESC= Tunnelblick XOR scramble patch (READ HELP!)
X509ALTUSERNAME_DESC= Enable --x509-username-field (OpenSSL only)
SMALL_DESC= Build a smaller executable with fewer features
@@ -49,6 +50,10 @@ EASYRSA_RUN_DEPENDS= easy-rsa>=0:security/easy-rsa
PKCS11_LIB_DEPENDS= libpkcs11-helper.so:security/pkcs11-helper
PKCS11_CONFIGURE_ENABLE= pkcs11
+PKCS11_PREVENTS= MBEDTLS
+PKCS11_PREVENTS_MSG= OpenVPN cannot use pkcs11-helper with mbedTLS. Disable PKCS11, or use OpenSSL instead
+
+TUNNELBLICK_EXTRA_PATCHES= ${FILESDIR}/extra-tunnelblick-openvpn_xorpatch
X509ALTUSERNAME_CONFIGURE_ENABLE= x509-alt-username