aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-devel
diff options
context:
space:
mode:
Diffstat (limited to 'security/openvpn-devel')
-rw-r--r--security/openvpn-devel/Makefile67
-rw-r--r--security/openvpn-devel/distinfo3
-rw-r--r--security/openvpn-devel/files/openvpn.sh.in103
-rw-r--r--security/openvpn-devel/files/patch-tests-for-jail67
-rw-r--r--security/openvpn-devel/files/pkg-message.in20
-rw-r--r--security/openvpn-devel/pkg-descr10
-rw-r--r--security/openvpn-devel/pkg-plist71
7 files changed, 0 insertions, 341 deletions
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
deleted file mode 100644
index 0133e3ae349b..000000000000
--- a/security/openvpn-devel/Makefile
+++ /dev/null
@@ -1,67 +0,0 @@
-# New ports collection makefile for: openvpn
-# Date created: 2002-06-23
-# Whom: Matthias Andree <matthias.andree@gmx.de>
-#
-# $FreeBSD$
-#
-
-PORTNAME= openvpn
-PORTVERSION= 2.0.5
-PORTREVISION= 1
-CATEGORIES= security net
-# MASTER_SITES points to hosts in distinct data centers,
-# so just one MASTER_SITES entry should be OK.
-MASTER_SITES= http://openvpn.net/release/
-
-MAINTAINER= matthias.andree@gmx.de
-COMMENT= Secure IP/Ethernet tunnel daemon
-
-GNU_CONFIGURE= yes
-USE_OPENSSL= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
- --with-lzo-headers=${LOCALBASE}/include
-
-MAN8= openvpn.8
-
-OPTIONS= PW_SAVE "Interactive passwords may be read from a file" off
-
-USE_RC_SUBR= openvpn.sh
-
-SUB_FILES= pkg-message
-
-.include <bsd.port.pre.mk>
-
-# NOTE: there is no way to explicitly specify the LZO version to OpenVPN,
-# if LZO2 and LZO1 are installed, OpenVPN will pick LZO2.
-# So depend on LZO1 only if it's already there and LZO2 isn't.
-# PACKAGE_BUILDING will also force LZO2.
-.if exists(${LOCALBASE}/lib/liblzo2.so.2) || !exists(${LOCALBASE}/lib/liblzo.so.1) || defined(PACKAGE_BUILDING)
-LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
-.else
-LIB_DEPENDS+= lzo.1:${PORTSDIR}/archivers/lzo
-.endif
-
-.if defined(WITH_PW_SAVE)
-CONFIGURE_ARGS+= --enable-password-save
-.endif
-
-# self-tests here
-post-build:
- cd ${WRKSRC} && ${MAKE} check
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL NEWS \
- PORTS README
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
-.endfor
- ( cd ${WRKSRC} \
- && ${FIND} easy-rsa sample-config-files sample-scripts -depth \
- | ${GREP} -v easy-rsa/Windows \
- | ${CPIO} -pdmu ${DOCSDIR} )
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/security/openvpn-devel/distinfo b/security/openvpn-devel/distinfo
deleted file mode 100644
index 6c8c6c6314f3..000000000000
--- a/security/openvpn-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (openvpn-2.0.5.tar.gz) = 4bd7a42991c93db23842a0992debe53b
-SHA256 (openvpn-2.0.5.tar.gz) = d72d90ff9e915c3376c834ce33a0349de0a8eacb3f2b80be49696b72a1840a9f
-SIZE (openvpn-2.0.5.tar.gz) = 662647
diff --git a/security/openvpn-devel/files/openvpn.sh.in b/security/openvpn-devel/files/openvpn.sh.in
deleted file mode 100644
index b4fc4dbba162..000000000000
--- a/security/openvpn-devel/files/openvpn.sh.in
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/sh
-#
-# openvpn.sh - load tun/tap driver and start OpenVPN daemon
-#
-# (C) Copyright 2005 by Matthias Andree
-# based on suggestions by Matthias Grimm and Dirk Gouders
-#
-# Made in Northrhine-Westphalia, Germany
-#
-# $FreeBSD$
-#
-# This program is free software; you can redistribute it and/or modify it under
-# the terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-#
-# This program is distributed in the hope that it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
-# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
-# details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 51 Franklin
-# Street, Fifth Floor, Boston, MA 02110-1301, USA.
-
-# PROVIDE: openvpn
-# REQUIRE: DAEMON
-# BEFORE:
-# KEYWORD: shutdown
-
-# -----------------------------------------------------------------------------
-#
-# Add the following lines to /etc/rc.conf to enable openvpn at boot-up time:
-#
-# openvpn_enable="YES" # YES or NO
-# openvpn_if="tun" # driver(s) to load, set to "tun", "tap" or "tun tap"
-#
-# # optional:
-# openvpn_flags="" # openvpn command line flags
-# openvpn_configfile="%%PREFIX%%/etc/openvpn/openvpn.conf" # --config file
-# openvpn_dir="%%PREFIX%%/etc/openvpn" # --cd directory
-#
-# You also need to set openvpn_configfile and openvpn_dir, if the configuration
-# file and directory where keys and certificates reside differ from the above
-# settings.
-#
-# Note that we deliberately refrain from unloading drivers.
-#
-# For further documentation, please see openvpn(8).
-#
-
-. %%RC_SUBR%%
-
-name=openvpn
-rcvar=`set_rcvar`
-
-prefix="%%PREFIX%%"
-
-openvpn_precmd()
-{
- for i in $openvpn_if ; do
- # FreeBSD <= 5.4 does not know kldstat's -m option
- # FreeBSD >= 6.0 does not add debug.* sysctl information
- # in the default build - we check both to keep things simple
- if ! sysctl debug.if_${i}_debug >/dev/null 2>&1 \
- && ! kldstat -m if_${i} >/dev/null 2>&1 ; then
- if ! kldload if_${i} ; then
- warn "Could not load $i module."
- return 1
- fi
- fi
- done
- return 0
-}
-
-stop_postcmd()
-{
- rm -f "$pidfile" || warn "Could not remove $pidfile."
-}
-
-# support SIGHUP to reparse configuration file
-extra_commands="reload"
-
-# pidfile
-pidfile="/var/run/${name}.pid"
-
-# command and arguments
-command="%%PREFIX%%/sbin/${name}"
-
-# run this first
-start_precmd="openvpn_precmd"
-# and this last
-stop_postcmd="stop_postcmd"
-
-load_rc_config ${name}
-: ${openvpn_enable="NO"}
-: ${openvpn_flags=""}
-: ${openvpn_if=""}
-: ${openvpn_configfile="${prefix}/etc/openvpn/openvpn.conf"}
-: ${openvpn_dir="${prefix}/etc/openvpn"}
-required_files="${openvpn_configfile}"
-command_args="--cd ${openvpn_dir} --daemon --config ${openvpn_configfile} --writepid ${pidfile}"
-run_rc_command "$1"
diff --git a/security/openvpn-devel/files/patch-tests-for-jail b/security/openvpn-devel/files/patch-tests-for-jail
deleted file mode 100644
index 6a0e72746ab6..000000000000
--- a/security/openvpn-devel/files/patch-tests-for-jail
+++ /dev/null
@@ -1,67 +0,0 @@
---- t_lpback.sh~
-+++ t_lpback.sh
-@@ -19,11 +19,13 @@
- # 02110-1301, USA.
-
- set -e
--trap "rm -f key.$$ log.$$ ; false" 1 2 3 15
-+trap "rm -f key.$$ log.$$ ; trap 0 ; exit 77" 1 2 15
-+trap "rm -f key.$$ log.$$ ; exit 1" 0 3
- ./openvpn --genkey --secret key.$$
- set +e
- ( ./openvpn --test-crypto --secret key.$$ ) >log.$$ 2>&1
- e=$?
- if [ $e != 0 ] ; then cat log.$$ ; fi
--rm key.$$
-+rm key.$$ log.$$
-+trap 0
- exit $e
---- t_cltsrv.sh~
-+++ t_cltsrv.sh
-@@ -19,20 +19,41 @@
- # 02110-1301, USA.
-
- set -e
-+trap "rm -f log.$$ log.$$.signal ; trap 0 ; exit 77" 1 2 15
-+trap "rm -f log.$$ log.$$.signal ; exit 1" 0 3
-+addopts=
-+case `uname -s` in
-+ FreeBSD)
-+ # FreeBSD jails map the outgoing IP to the jail IP - we need to
-+ # allow the real IP unless we want the test to run forever.
-+ if test "`sysctl 2>/dev/null -n security.jail.jailed`" = 1 \
-+ || ps -ostate= -p $$ | grep -q J; then
-+ addopts="--float"
-+ if test "x`ifconfig | grep inet`" = x ; then
-+ echo "###"
-+ echo "### To run the test in a FreeBSD jail, you MUST add an IP alias for the jail's IP."
-+ echo "###"
-+ exit 1
-+ fi
-+ fi
-+ ;;
-+esac
- echo "the following test will run about two minutes..." >&2
--trap "rm -f log.$$ ; false" 1 2 3 15
- set +e
- (
--./openvpn --cd "${srcdir}" --config sample-config-files/loopback-server &
--./openvpn --cd "${srcdir}" --config sample-config-files/loopback-client
--) >log.$$ 2>&1
-+./openvpn --cd "${srcdir}" ${addopts} --down 'echo "srv:${signal}" >&3 ; : #' --tls-exit --ping-exit 180 --config sample-config-files/loopback-server &
-+./openvpn --cd "${srcdir}" ${addopts} --down 'echo "clt:${signal}" >&3 ; : #' --tls-exit --ping-exit 180 --config sample-config-files/loopback-client
-+) 3>log.$$.signal >log.$$ 2>&1
- e1=$?
- wait $!
- e2=$?
-+grep -v ":inactive$" log.$$.signal >/dev/null && { cat log.$$.signal ; echo ; cat log.$$ ; exit 1 ; }
-+
- set -e
-
- if [ $e1 != 0 ] || [ $e2 != 0 ] ; then
- cat log.$$
- exit 1
- fi
--rm log.$$
-+rm log.$$ log.$$.signal
-+trap 0
diff --git a/security/openvpn-devel/files/pkg-message.in b/security/openvpn-devel/files/pkg-message.in
deleted file mode 100644
index 7b6d0e6cbfa0..000000000000
--- a/security/openvpn-devel/files/pkg-message.in
+++ /dev/null
@@ -1,20 +0,0 @@
-### ------------------------------------------------------------------------
-### The OpenVPN FreeBSD port, since v2.0.1, uses rcNG to start OpenVPN.
-### Edit /etc/rc.conf to start OpenVPN automatically at system startup.
-### See %%PREFIX%%/etc/rc.d/openvpn.sh for details.
-### ------------------------------------------------------------------------
-### To get OpenVPN 1.X to talk with the new 2.0 version, you may need to
-### edit the 1.X configuration file by adding these lines:
-### tun-mtu 1500
-### tun-mtu-extra 32
-### mssfix 1450
-### key-method 2 <- this key-method line only for TLS setups
-### - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
-### WARNING: THE DEFAULT PORT HAS CHANGED AND IS NOW 1194!
-### OpenVPN 1.6 and older used 5000 rather than 1194 as their default
-### port, so add the proper port options to your configuration file!
-### - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
-### For further compatibility, see <http://openvpn.net/relnotes.html>
-### ------------------------------------------------------------------------
-### If you want to donate to OpenVPN: <http://openvpn.net/donate.html>
-### ------------------------------------------------------------------------
diff --git a/security/openvpn-devel/pkg-descr b/security/openvpn-devel/pkg-descr
deleted file mode 100644
index b527fa8fa75e..000000000000
--- a/security/openvpn-devel/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-OpenVPN is a robust, scalable and highly configurable VPN (Virtual Private
-Network) daemon which can be used to securely link two or more private networks
-using an encrypted tunnel over the internet. It can operate over UDP or TCP,
-can use SSL or a pre-shared secret to authenticate peers, and in SSL mode, one
-server can handle many clients.
-
-WWW: http://openvpn.net/
-
-- Matthias Andree
-matthias.andree@gmx.de
diff --git a/security/openvpn-devel/pkg-plist b/security/openvpn-devel/pkg-plist
deleted file mode 100644
index 44883fb1103d..000000000000
--- a/security/openvpn-devel/pkg-plist
+++ /dev/null
@@ -1,71 +0,0 @@
-sbin/openvpn
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT.GPL
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/PORTS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-ca
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-dh
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-key
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-key-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-key-pkcs12
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-key-server
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-req-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/clean-all
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/list-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/make-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/openssl.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/revoke-crt
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/revoke-full
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/sign-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/vars
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-ca
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-dh
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-pkcs12
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-server
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-req-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/clean-all
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/inherit-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/list-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/openssl.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/pkitool
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/revoke-full
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/sign-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/vars
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/README
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/client.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/firewall.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/home.up
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/loopback-client
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/loopback-server
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/office.up
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/openvpn-shutdown.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/openvpn-startup.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/server.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/static-home.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/static-office.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/tls-home.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/tls-office.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/xinetd-client-config
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/xinetd-server-config
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/auth-pam.pl
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-start
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-stop
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/openvpn.init
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/verify-cn
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-scripts
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-config-files
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa/2.0
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa
-%%PORTDOCS%%@dirrm %%DOCSDIR%%